DSG error "Gearbox malfunction, you may continue driving. Limited functionality."

Car is a 2012 TFSI Avant with ~8000 miles on the clock.

I had this error on Sunday, about 10 miles into my drive home (with ~20miles still to go - pouring rain and the wife + my three very young kids in the car!): "Gearbox malfunction, you may continue driving. Limited functionality."

... which then changed to a warning triangle on the DIS and the letter R crossed out and the text "Reverse not available" in the more info section.

I thought it was clutch at first, since the car seemed to be surging and then slowing down every time it changed gears... then I realised that it was only allowing gears 1-3-5-7 (ie. half the DSG gearbox)

Workarounds (very short term):
1) driving: I was able to drive home fine, steady cruising was easy, but town traffic was a mess: had to put it in Sport and allow it to rev to ~6500rpm in 1st, so when it then shifted to 3rd it wasn't "reaching too far".... otherwise it was changing up and pushing the revs down to ~500rpm.... which might be okay in a diesel, but the supercharged V6 petrol needs around 750-900rpm to pull smoothly....
2) parking/reversing: in true "IT Crowd"/IT support style, if I switched the car off and back on again, I could select reverse for a minute or two.... enough to slot the car back into my driveway when I got home.

I Googled the alert when I got home.... it's a common issue for the 2010-2012 S4 (same engine + gearbox as mine).... lots of threads about a software update and/or mechatronics, plus a few (US) threads with the same issues for the A6 3.0 TFSI.

I popped the car into the local Audi: despite saying they could only guaranteed me a diagnostics session in 14days, they said they would try to get somebody to at least do a first look ASAP - and were able to get that done in <24h!!

Fortunately I had mentioned that the mechatronics were a known issue on the <2012 DSG for the 3.0TFSI, even at <10k miles.... as they confirmed that it is the mechatronics - Audi have indicated that they will cover the cost, despite the car being (1 month) out of manufacturer's warranty!! TBC on the details of that, but fingers crossed - really decent of them to pick that up, if they do!!
 
Car was one month out of the 3yr warranty :|

But Audi picked up the Mechatronic parts bill and the Dealership (Walton - Drifbridge) picked up the labour charges... from what I can work out, it is at least half a day of shop-time as it really is the insides of the gearbox that need to be replaced! To be fair I did just drop the car off with them and said "see when you can fit it in", so I was also being pretty flexible.

And as a bonus: they did my 3yr brake fluid change free of charge too!!

Serious relief!
 
yep - definitely a significant step beyond where I was hoping they would go to... and the brake fluid work (£~160), was just icing on the (already substantial) cake!

The main chap dealing with me even went on holiday in the middle of it and the handover between their staff was seamless: the guy who called me to say the car was ready had all the notes to say that all the gearbox work was covered - and the original person was back by the time I returned to pick up the car, so I'm pretty confident the brake fluid thing wasn't a mistake too...
 

elan2s

Registered User
Car was one month out of the 3yr warranty :|

But Audi picked up the Mechatronic parts bill and the Dealership (Walton - Drifbridge) picked up the labour charges... from what I can work out, it is at least half a day of shop-time as it really is the insides of the gearbox that need to be replaced! To be fair I did just drop the car off with them and said "see when you can fit it in", so I was also being pretty flexible.

And as a bonus: they did my 3yr brake fluid change free of charge too!!

Serious relief!
Great to hear another positive report for Walton. I have used them for service for the last 20 years and also bought my last 2 A6s from them. Your car must have been downstairs being looked at whilst I was upstairs collecting my new A6 on the 29th July.
 
It was over ten years ago, it must be said - so not recent enough or bad enough to warrant a negative review, but after some decidedly unimpressive service from Epsom Audi, I was nervous about going to another Driftbridge Audi dealership when I was caught in a pinch (~7yrs ago) with a Xenon headlight issue that I thought merited main dealer attention. Walton was by far the most convenient for me to get to (by rail especially) - so I thought I'd give it a go. I haven't had a moment's doubt about them ever since - really very good in every way: they really try to make things as convenient (and affordable!) for you at every opportunity and top quality service.

I even dropped them a line to ask about what size wheels I could use for winter wheels as I was wanting to put a set of 17" alloys (from an A6 C7 TDI on this forum) and one of their mechanics called me back an hour or so later to provide the answer ("no") and explanation (brake caliper clearance).

I've always had my reservations about main dealers in general - especially after my E30 BMW days - eye-wateringly more expensive than Indy's and with an inflexible "our way or the highway" approach to everything. After my very limited dealings with Epsom, when I was ordering in parts for my old Golf, I thought the Audi dealers might be the same: but Walton have completely reversed my opinion of that whole category...
 

cata_adc

Registered User
Same error for me in this morning.
I'm also warranty out.
What did you do in the end
Thanks mate
 

cata_adc

Registered User
from VCDS the fault codes are :
8026 - Valve 1 in Transmission Part 2
P174C 00[109] - Elecrical malfunction
8093 - Gear Selector 1 Cannot be Regulated
P176a 00[175]

only first gear is working nothing more.
we will see what is to be done
 
I thought they did a recall on the DSG 3.0 s charged, but not sure about the smaller engines.

Cata's issue doesn't sound like the same mechatronic failure that the did the recall on though. That issue, you will still have half the gearbox.
 

cata_adc

Registered User
Thank you for the reply. My engine is 3.0 TDI car is 2012 year CDUC engine code
Yes I was looking for that recall but my problem is a little bit different, the onboard error is the same . No reverse gear , only first gear is sworking nothing elese. Also the manual is inoperative.
BahnStormer77 what errors did you get in the gearbox computer ?
Now it was close to the gearbox oil change 119.000 km
 

cata_adc

Registered User
Got the answer .
The mecahatronic unit has one valve for 2nd gear and reverse damaged
need to replace the mechatronic unit and this is quite an expensive part ...
I've had many cars late but this C7 has the worst service issues

It will be my last Audi, it's a shame :sign unfair:
 
I never put the RossTech cable in. I just saw the alert (as per this thread subject), Googled it and took it straight to the dealer.

Mine was just letting me run on the 1-3-5-7 half of the gearbox and if I turned it all off and back on again, I had the full gearbox for a minute or two....
 

cata_adc

Registered User
New mechatronic unit , new gearbox oil and filter and the car is back on the road
I was courious what errors did you get.
 

Attachments

  • qhDbu1I.jpg
    qhDbu1I.jpg
    736.5 KB · Views: 10,938
As per the title: "Gearbox malfunction, you may continue driving. Limited functionality"

I never plugged in the Rosstech OBD2 cable, so never took a dump of all the error codes.
 
Top