Drive Select...

cactusgreen

Registered User
Having got nowhere asking the dealer, can anyone tell me is this normal: when selecting efficiency I get a green dash telltale that says efficiency, the climate switches to an eco mode, and Drive goes to E1....and you float about like a granny...stop, engine off. Return and the display still says efficiency on the dash and climate, but now returned to D1. So I'm guessing it's some half programme . Also noticed the econ meter goes into a green battery thing in D but not in E....
 

quattrorally

Registered User
Having got nowhere asking the dealer, can anyone tell me is this normal: when selecting efficiency I get a green dash telltale that says efficiency, the climate switches to an eco mode, and Drive goes to E1....and you float about like a granny...stop, engine off. Return and the display still says efficiency on the dash and climate, but now returned to D1. So I'm guessing it's some half programme . Also noticed the econ meter goes into a green battery thing in D but not in E....

what do you mean by return?
 

cactusgreen

Registered User
After a trip, you stop and turn off...when you come to leave again
 

Spinstorm

Registered User
Yes its normal. The car always returns to its default mode when you turn the engine off and on even though it shows the last mode.
 

quattrorally

Registered User
Same here.
Well I hate to disagree but on my RS3 it will say it’s in dynamic if it was in dynamic when I turned the car off.
But it isn’t in dynamic. It resets to standard. It just says dynamic.
So this behaviour is normal.
Same here.
 

JohnM100

Registered User
VCDS Map User
Gold Supporter
Gearbox always goes back to Auto after an engine off period, regardless of whether you were in Dynamic or Efficiency.

Other settings e.g. weight of steering are unchanged.

The mode displayed on screen doesn’t change.
 

Audi-Sport-Driver

Active Member
Well I hate to disagree but on my RS3 it will say it’s in dynamic if it was in dynamic when I turned the car off.
But it isn’t in dynamic. It resets to standard. It just says dynamic.
So this behaviour is normal.
I will try..
Maybe it's because I always manually go back to efficiency..
 

Audi-Sport-Driver

Active Member
Gearbox always goes back to Auto after an engine off period, regardless of whether you were in Dynamic or Efficiency.

Other settings e.g. weight of steering are unchanged.

The mode displayed on screen doesn’t change.
Just tried any modes I leave it stay last used never goes to any "default" soo
you have probably Facelifts and audi changed it?
I would notice this long time ago if this would happen and would complain here.. ¯\_(ツ)_/¯
 

JohnM100

Registered User
VCDS Map User
Gold Supporter
Just tried any modes I leave it stay last used never goes to any "default" soo
you have probably Facelifts and audi changed it?
I would notice this long time ago if this would happen and would complain here.. ¯\_(ツ)_/¯

So, in dynamic mode: turn the engine off, lock car, unlock, start engine and move gear lever to D ready to drive off (without the extra pull back to change between D/S): does it say S on the dash or D for gearbox mode?

My PFL and FL behave in the same way.
 

cactusgreen

Registered User
So we've basically established drive select stays at what you set, but reverts most if not all settings to I guess auto when you switch off. 10 + years of development and basically Audi still can't leave a setting set lol. My S4 (2010) reverts back, but at least you know it with a nice bright led back on auto....
 

Audi-Sport-Driver

Active Member
So, in dynamic mode: turn the engine off, lock car, unlock, start engine and move gear lever to D ready to drive off (without the extra pull back to change between D/S): does it say S on the dash or D for gearbox mode?

My PFL and FL behave in the same way.
I will try it after work :)
 

gforrow

Registered User
From what I have been told, and this affects all VW group cars, as well as MB, Volvo etc I have recently had as hire cars, is that this is the programmed behaviour. It's so that if someone else gets in the car, wife, partner, whatever, it is in a default driving mode.

No one has ever been able to explain why the dash doesn't change to Auto though, but it is certainly not a VW issue, seems widespread.
 

JohnM100

Registered User
VCDS Map User
Gold Supporter
Also to protect the gearbox from hard gear changes when cold.
 

Mikeso51

Registered User
There was a long thread about Drive Select reverting after an ignition cycle, and one forum member posted a very helpful screenshot from the screen of the master technicians pc at his local Audi dealer. I have reproduced it below.
BFF8D95E-AD0A-4EB1-96B9-70DA19F406F7.png
 
Top