DPF light followed by emission control system light

StuF

Registered User
The dpf light on my 2009 A4 2.0 tdi CR170 has been on and off for the last couple of weeks. This was followed today by the emission control system light which is on continuously. I'm assuming these two are related?

The car is driving fine by the way. Anyone any other ideas or do I need to get the error codes pulled first?

Cheers :)
 

hollows wife

Registered User
basically its warning you the dpf is full . or it could be the pressure sensor on the dpf gone faulty .

get the error codes and get them to check the ash mass of the dpf .
 

@udi A3

Well-Known Member
VCDS Map User
Where are you based, i may be able able to check and regenerate it if your driving style doesnt allow it to.
 

StuF

Registered User
basically its warning you the dpf is full . or it could be the pressure sensor on the dpf gone faulty .

get the error codes and get them to check the ash mass of the dpf .

Cheers fella. Will get the codes pulled as soon as I can. Getting married at the weekend so probably won't get a chance till next week. If I leave it will it eventually go into limp mode? As I've already decided I'll be getting the dpf deleted and the car mapped
 

hollows wife

Registered User
next stage if dpf is full is limp mode when you try to boot it, as it doesnt look like its doing a regen .
All the best for your wedding day ,congrats to you + your future wife
 

StuF

Registered User
next stage if dpf is full is limp mode when you try to boot it, as it doesnt look like its doing a regen .
All the best for your wedding day ,congrats to you + your future wife

Thanks fella, that's very much appreciated :)

Ok, will take it for a another spin and try and force a regen tomorrow. If it goes into limp mode, how driveable will it be? Is it simply a case of not being able to generate any boost or does it limit revs? Wouldn't normally be a problem but I'm short on free time at the minute lol
 

NVM

Registered User
Limp mode will reduce turbo pressure and revlimit in everygear at 3000rpm.

a dpf delete and remap is what you need.
 

StuF

Registered User
Thought as much, the emission control light has gone off today but I suspect it'll make a reappearance lol.
 

@udi A3

Well-Known Member
VCDS Map User
as per pm happy to plug u in and check soot levels on route to the meet oop north :D
 

Zafi

Registered User
Mine was exactly same. Turned out to be the sensor. £85 fitted at Vastech in Northallerton.
 

Zafi

Registered User
I tried 4000 rpm for 20 miles, did not cure it. Then I plugged in and it all became clear.....
 

StuF

Registered User
Sorry lads just got back off my hols so haven't looked at the thread in a while. Error light is still on the dash and the car is still driving fine. Tried driving 20 odd miles at high rpm with no joy.

Car will hopefully be getting the fault codes pulled on Saturday ;)
 

StuF

Registered User
Update :)

Tom (@udi A3) very kindly plugged the car in tonight. Turns out the DPF is fine and a sensor has gone.

5253 - Diesel Particle Filter; Differential Pressure Sensor
P2452 00 [039] - Elect. Malfunction
Not Confirmed - Tested Since Memory Clear

So it looks like it's going to a cheap fix :)
 
Top