Down on power

chaz1702

Registered User
image.jpeg
hi all my sisters s3 2.0 tdi 05 is down on power and just not running right I am due to service it anyway but the check engine light is on I have plugged in with Delphi clone pease see attached photo the car idles rough, apparently it cut out on her the other day on the motorway and ever since hasn't been quite right but then the other day it wouldn't go over 2500 Rpms and was sluggish getting there any help appreciated cheers Charlie ps I have wiped codes and going to take it for a drive and see what we get back
 

chaz1702

Registered User
Is there a way to check it as I looked at the live data and as I revved the engine up the value increased so could it be a split pipe somewhere and is that the reason the turbo light came on as well?
 

SootySport

Registered User
Splits are hard to find, take off the undertray and engine cover first. You need to feel each I/Cooler pipe and press the rubber in to find them. They are not always visible to the eye when the engine is switched off. If you still can't find a damage hose, renew all the hose seals and clips. Also near impossible to find with the engine running, everything is too damn hot but you may see/hear a leak with a torch.
 

chaz1702

Registered User
Its been driven about a bit more and the light has not come back on, when you rev it up it revs itself slightly and hisses when you let go had a look and sprayed brake and clutch cleaner at some pipes at the rhs near the cabin and it revved up, should the egr pipe have a liquid in it? help appreciated
 

chaz1702

Registered User
Also it can be very juddery when driving as the acceleration cuts out and then starts again, not a smooth acceleration
 

lgooch

Well-Known Member
VCDS Map User
I would get a new MAF and a smoke test done on it
 
Top