Door open warning help

Mike.M

Registered User
Been getting every now and then a warning on the DIS about the drivers door being open when it is not.......about once a week

Anyone had this and if so have you managed to cure it yourself?

Called Audi and its booked in, but said if it is to be serviced/oiled etc I will pay for it otherwise if replaced it will be done under warranty.
 

cclarke184

Registered User
I also have this problem on my A3, i notice it only plays up in hot weather, i can only assume that some thing is expanding in the heat.
This also has a knock on effect that when lock the car it some time thinks that the door is still open and doesn't set the alarm fully (if at all).
 

Anito

Registered User
I had a similar problem on my A4, except this was failing to tell me a door was open /ubbthreads/images/graemlins/mad.gif

They changed the part under warranty
 

pazaz

Registered User
Mines doing it all the time /ubbthreads/images/graemlins/froggie_red.gif

Its out of warranty so i hope its not too expensive..

Tried some Wd40 but still the same.
 

darkspin

Registered User
surprise surprise im having the same issue also, ive noticed that it plays up in the heat otherwise its ok on cooler days. When i called my local Audi dealer they said the cost of it depends on what needs doing so it ranged from £100 to £500 /ubbthreads/images/graemlins/shocked.gif but im assuming it shouldnt be latter really
 

chimmo

Registered User
I'll add myself to this list as I had the exact same problem with my A3 last year...

Replacement door lock fitted resolved the problem, fortunately for me all done under warranyy. The price for the job against my car was £149.33 but I couldn't tell you if that's the cost of the part only or including fitting too.... /ubbthreads/images/graemlins/crazy.gif as it was done under warranty

/ubbthreads/images/graemlins/beerchug.gif
 

S3_MCD

Registered User
me too, drivers side.
1st occurance last week, car was HOT. opening and slammin the door a few times sorted it.... for now. /ubbthreads/images/graemlins/smile.gif
 

HTC

Registered User
The drivers door usually gets used alot more than the passenger door.

Simple wear and tear I guess.

It costs a bit as you need to remove the door subframe to get to it.
 

peteA3tdi

Registered User
my passenger side is playing up with the engine off open the door and the dome light comes on with the engine running with the door open it flashes like a disco waiting for maidstone audi to change it under warranty
 

Mike.M

Registered User
I had that too.

Seems to be behaving at the moment
 

Kevint

Registered User
Had the same on an older A3 of mine, only in warm weather.

The car does lock but it does not set the alarm!

Kev.
 

speedyp

Registered User
[ QUOTE ]
peteTDI said:
waiting for maidstone audi to change it under warranty

[/ QUOTE ]

You'll be waiting quite a while for that then!!! /ubbthreads/images/graemlins/lol.gif

I was going to get my service done there (2nd AVS) they wanted £ 360.... plus a 3 week waiting list!

Going to get it done in Plymouth, when I visit my other half, for only £ 275 & any time after a week /ubbthreads/images/graemlins/grin.gif /ubbthreads/images/graemlins/grin.gif
 
I

imported_alwinharrison

Guest
I think I was on it for about an hour and a half.

The worst bit is aligning the door subframe assembly up when you replace it in the door. It fixes with four Torx bolts (Tx 45 I think), the bottom two have wedge shims behind to alter the angle of the door frame/glass assembly, and the whole thing is height adjustable also

Needs a bit of fiddling to get the door closure fit right. Make sure the door fit is OK before refitting the door trim.

otherwise if you have done a bit its fairly straightforward.
 
I

imported_alwinharrison

Guest
Mine got worse over six months or so, at first it was only doing it very occasionly when car had been in the sun.

In the finish it would do it almost every time the car had been driven a while.

Since stripping and lubeing the switch it has been behaving.( Up to press)
 

Defratos

You’re Dethpicable!!
I had the same problem with my old 1.8SE, got it sorted by Audi somehow, not sure what was wrong
 
I

imported_ashs3

Guest
I had the same thing, phoned my dealer and they said "bring it in, it is the door lock that needs replacing, it's a common problem on the S3 drivers door" so took it in and they sorted it under warranty /ubbthreads/images/graemlins/grin.gif
 
Top