DAB retrofit

swampdonkeygj

Registered User
Hi everyone, have been trying to install DAB today and ran into a few problems.

I bought a DAB radio module 4F0 035 061 B from ebay.de for £140, then bought the amplifier (4F9 035 225 S), 3 pin connector (1C0 983 119 B), captive nut (WHT 000 011) and screw (N 106 569 01) from Audi, along with a couple of repair wires, all of which cost me £55.91. I then bought a 6m cable with Fakra connectors to connect the radio module to the amplifier from Car Electronics on Ebay for £10..

Following this thread - VW Audi Forum - The #1 VW Group Community - I started by removing the interior trim I need to take out in order to run the cabling, and install the amplifier. As I didn't fancy soldering the wiring to the window, I bought some conductive paint but I just couldn't get on with it at all, too thin and was taking way too long to dry. So for the time being I have gaffer taped the cable conductors to just test that everything works, and think I have found another solution so just waiting for that to arrive.

I then took out my old radio unit, fitted the DAB radio unit, and connected up the 3 existing connectors and the new DAB amplifier connection. I turned the ignition on to see whether it had worked. I could now select DAB, and there was a huge list of DAB stations, but no audio. So I took the car to my friends garage as he has VCDS and borrowed his laptop. I enabled digital radio in the application list, but still no joy. I did a full scan and got the following:

Thursday,08,September,2016,16:50:54:55487
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
VCDS Version: 16.8.1.3 (x64)
Data version: 20160902 DS256
Ross-Tech: Home

VIN: WAUZZZ4F7BN071876 License Plate:

Chassis Type: 4F (4F0)
Scan: 01 02 03 05 08 09 0E 0F 15 16 17 19 42 46 4F 52 53 55 56 5F
62 72 76

VIN: WAUZZZ4F7BN071876 Mileage: 174060km-108155miles

01-Engine -- Status: OK 0000
02-Auto Trans -- Status: OK 0000
03-ABS Brakes -- Status: OK 0000
04-Steering Angle -- Status: OK 0000
05-Acc/Start Auth. -- Status: OK 0000
08-Auto HVAC -- Status: OK 0000
09-Cent. Elect. -- Status: OK 0000
0E-Media Player 1 -- Status: OK 0000
0F-Digital Radio -- Status: Cannot be reached 1100
15-Airbags -- Status: OK 0000
16-Steering wheel -- Status: OK 0000
17-Instruments -- Status: OK 0000
19-CAN Gateway -- Status: Malfunction 0010
42-Door Elect, Driver -- Status: OK 0000
46-Central Conv. -- Status: OK 0000
4F-Centr. Electr. II -- Status: OK 0000
52-Door Elect, Pass. -- Status: OK 0000
53-Parking Brake -- Status: OK 0000
55-Headlight Range -- Status: OK 0000
56-Radio -- Status: Malfunction 0010
5F-Information Electr. -- Status: Malfunction 0010
62-Door, Rear Left -- Status: OK 0000
72-Door, Rear Right -- Status: OK 0000
76-Park Assist -- Status: OK 0000

And the relevant fault codes:

Address 0F: Digital Radio
Cannot be reached

-------------------------------------------------------------------------------
Address 19: CAN Gateway (J533) Labels: 4F0-907-468.clb
Part No SW: 4F0 907 468 M HW: 4F0 907 468 F
Component: GW-BEM 4CAN-M H06 0035
Revision: LB100029 Serial number: 2900L113058029
Coding: 000303
Shop #: WSC 02391 823 56573
VCID: 3979D9BEB0812D8AA9-806C


Subsystem 1 - Part No SW: 8K0 915 181 C HW: 8K0 915 181 C
Component: J367-BDM H07 0125
Serial number: 00000000002790711947


2 Faults Found:
02095 - Component Protection Active
000 - -
Freeze Frame:
Fault Status: 01100000
Fault Priority: 1
Fault Frequency: 2
Reset counter: 180
Mileage: 174061 km
Time Indication: 0
Date: 2016.09.08
Time: 15:03:49


Freeze Frame:
Bin. Bits: 10111
Voltage: 11.60 V
Count: 7
Text: FF30746C20023100
Text: FF30746C20023100
(no units): 29688.0
(no units): 49.0


02230 - Digital Radio (DAB) (R147)
004 - No Signal/Communication
Freeze Frame:
Fault Status: 01100100
Fault Priority: 3
Fault Frequency: 1
Reset counter: 180
Mileage: 174066 km
Time Indication: 0
Date: 2016.09.08
Time: 16:36:11


Freeze Frame:
Bin. Bits: 10111
Voltage: 11.90 V
Count: 7
Bin. Bits: 10011

Address 56: Radio (R) Labels: Redir Fail!
Part No SW: 4F0 035 061 H HW: 4F0 035 061
Component: Radio U DAB H45 0048
Revision: AB001007 Serial number: 343H$097527664
Coding: 010105010000000002
Shop #: WSC 06443 128 28888
VCID: 214911DE3811554A81-8074


2 Faults Found:
02095 - Component Protection Active
000 - -
Freeze Frame:
Fault Status: 01100000
Fault Priority: 4
Fault Frequency: 1
Reset counter: 179
Mileage: 174061 km
Time Indication: 0
Date: 2016.09.08
Time: 15:02:56


02095 - Component Protection Active
008 - Implausible Signal - Intermittent
Freeze Frame:
Fault Status: 00101000
Fault Priority: 4
Fault Frequency: 1
Reset counter: 219
Mileage: 174061 km
Time Indication: 0
Date: 2016.09.08
Time: 15:02:56

-------------------------------------------------------------------------------
Address 5F: Information Electr. (J794) Labels: 4E0-035-6xx-5F.clb
Part No SW: 4E0 035 666 H HW: 4E0 035 666 C
Component: H-BN-EU H51 0174
Revision: -------- Serial number: 454CX0B7583260
Coding: 010101010002C3ED01000315EF6300030001
Shop #: WSC 02391 823 56573
VCID: 2B55F3F64ADD8F1A2B-807E


Subsystem 1 - Part No: 8R0 060 884 N
Component: EUR 2011 1205


Subsystem 2 - Part No SW: 8F0 919 604 HW: 8F0 919 604
Component: DU7 High H43 0098
Serial number: 9466C-0B0546169


Subsystem 3 - Part No SW: 4F0 910 609 E HW: 4F2 919 611 M
Component: Bedienteil MM H01 0060
Serial number: 00000001804936


Subsystem 4 - Part No: 8R0 060 961 A
Component: CD-Database 2712


3 Faults Found:
03276 - Please Check Software Version Management
000 - -
Freeze Frame:
Fault Status: 01100000
Fault Priority: 6
Fault Frequency: 1
Reset counter: 180
Mileage: 174066 km
Time Indication: 0
Date: 2016.09.08
Time: 16:35:21


Freeze Frame:
Voltage: 12.40 V


00384 - Optical Databus
011 - Open Circuit - Intermittent
Freeze Frame:
Fault Status: 00101011
Fault Priority: 5
Fault Frequency: 1
Reset counter: 220
Mileage: 174066 km
Time Indication: 0
Date: 2016.09.08
Time: 16:33:17


Freeze Frame:
Voltage: 12.70 V


00822 - Connection DSP to Radio
004 - No Signal/Communication
Freeze Frame:
Fault Status: 01100100
Fault Priority: 5
Fault Frequency: 1
Reset counter: 180
Mileage: 174066 km
Time Indication: 0
Date: 2016.09.08
Time: 16:35:24


Freeze Frame:
Voltage: 12.60 V


So for the time being I have connected the old radio unit up until I can try and work out what's going on. The component protection codes I was expecting, but not the others, so I've been trying to do a bit of research. Seems that the 03276 - Please Check Software Version Management fault code can be easily sorted. What concerns me more at the moment is the 00384 - Optical Databus intermittent open circuit, 00822 - Connection DSP to Radio and 02230 - Digital Radio (DAB) (R147). I am going to try cancelling the 384 code to see if the code was cause by swapping the MOST connector over to the new radio unit. There is definitely a light out of the optical cable. The other 2 I have not found much info on yet, not in English at least. I'm just hoping the radio unit isn't faulty.

Has anybody seen this issue before themselves?

Thanks for reading.
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Resolve cp then see what happens.
 

swampdonkeygj

Registered User
Resolve cp then see what happens.

Thanks, do you think that could possibly resolve my no audio issue?
 

Simon968

Registered User
When I upgraded to DAB on my 3G MMI I had no audio whilst CP was active.

I would also add that removing component protection was a pain. My local Audi dealership had originally given me a quote to do it, but when I went over to book it in (gave up phoning as the Service Department never returns my calls) they refused to do it unless I had either bought the unit from them or from TPS.
I found a local garage with Autoscan diagnostic equipment who said that they could do it, but it still took them 3 goes to do it and they couldn't / wouldn't do the coding to make it work properly. Fortunately another member on here doesn't live too far from away and sorted that out for me.
 
Last edited:

B5NUT

Well-Known Member
VCDS Map User
The coding on the AMP is wrong the internal amplifier is disabled so you won't get any sound, try this coding 01010302010000000000. Also component protect is enabled this could also cause problems, if it does then you need to visit your local Audi dealer and get it removed.

Also remove 0F from the gateway, that is the old DAB 2G module.

Use this page to help remove the "03276 - Please Check Software Version Management" on the 5F module http://www.audienthusiasts.com/Application_SVMError.html

Once you have done all that clear all the fault codes and you should be all fixed.
 

swampdonkeygj

Registered User
B5NUT I have coded the radio module as you said and now it is working, but with intermittent sound which I think is down to the CP. I called my local Audi dealer who flatly refused to have anything to do with this, so I've booked the car in with the local specialist who say they can help me out.

Thanks for your help.
 

swampdonkeygj

Registered User
I managed to complete the DAB install and everything is working as it should now. The local Audi dealer would have nothing to do with removing the CP, but fortunately the local specialist was able to do it.

As I wasn't comfortable soldering the wires from the amplifier to the antenna contact points on the window, I used a conductive paint, which I found really good to use. It's called bare conductive and came in a squeezy tube.

I did a scan today and I still have a couple of fault codes.

2 Faults Found:
02877 - Digital Radio Antenna (R183)
012 - Electrical Fault in Circuit
Freeze Frame:
Fault Status: 01101100
Fault Priority: 7
Fault Frequency: 1
Reset counter: 222
Mileage: 176566 km
Time Indication: 0
Date: 2016.09.24
Time: 17:01:05


Freeze Frame:
Voltage: 11.40 V


03175 - Invalid Data Set
000 - -
Freeze Frame:
Fault Status: 01100000
Fault Priority: 4
Fault Frequency: 3
Reset counter: 222
Mileage: 176566 km
Time Indication: 0
Date: 2016.09.24
Time: 17:00:55


Freeze Frame:
Voltage: 11.40 V
Bin. Bits: 00000000 00001110

I have the RC terminal cabled to the top and bottom antenna points on the window, and the DAB terminal cabled to the middle.

If I clear the codes and check again the codes return. Has anybody else seen this?

Thanks,
 

B5NUT

Well-Known Member
VCDS Map User
03175 - Invalid Data Set could be down to a firmware the AMP is running, have you updated the firmware?

02877 - Digital Radio Antenna (R183) Have you wired it correctly? one wire should go to the screen the other 2 pins should be looped together.
 

swampdonkeygj

Registered User
03175 - Invalid Data Set could be down to a firmware the AMP is running, have you updated the firmware?

02877 - Digital Radio Antenna (R183) Have you wired it correctly? one wire should go to the screen the other 2 pins should be looped together.

Hi,

Thanks for replying - no I have the RC terminal cabled to the top and bottom antenna points on the window, and the DAB terminal cabled to the middle, as detailed in one of the guides I found on vwaudiforum. And no I haven't updated the firmware, I will see if I can find how to do it.
 

swampdonkeygj

Registered User
I have noticed an issue with AMI, that when I have my iPhone connected, and somebody calls me, it will ring through the speakers but the MMI doesn't show that there is a call, and I cannot answer the call at all.

If I have my phone on silent, and someone calls, then the sound via AMI will cutout completely, and I cannot get it to come back on.
 
Top