Creaking noise from front end

ilim

Registered User
I've recently been getting a creaking/squeaking noise from the front end of the car when going over speed bumps. This only happens at speed bumps. Sounds like its might be coming from the top of the strut on both sides.
The car is lowered on H&R springs and has H&R front and rear ARBs. Has anyone experienced this before. The car has only done 5k miles so I'm assuming the dampers won't have packed in yet.



Ilim
 

max69vk

Registered User
Check the steering rack, it's quite common on the A3 for this to happen when they're lowered.
 

ilim

Registered User
Check the steering rack, it's quite common on the A3 for this to happen when they're lowered.

checked the steering rack, just happens on speed bumps on both sides. Was thinking maybe the drop links?
 

mohsin1315

Registered User
How long have the springs been fitted? I have this on the rear after having a h&r cup kit fitted a couple of weeks ago. Been told the springs still need to settle. Would've thought two weeks would be enough time.
 

ilim

Registered User
How long have the springs been fitted? I have this on the rear after having a h&r cup kit fitted a couple of weeks ago. Been told the springs still need to settle. Would've thought two weeks would be enough time.


Hey dude, I've had them fitted for ages, on my current s3 and previous s3. They are getting checked on Monday, my bets on the front Anti roll bars.

Who installed your H&R cup kit?
 

Tay

Active Member
VCDS Map User
Have you checked the condition of the bushes? If these are worn they could be making a squeak/creek noise when going up or down speed bumps.
 
Top