Coding for aircon / window defogger

pierreluigi88

Registered User
I have a couple of questions around this subject - @DJAlix could you possibly help?

1) When changing drive select away from Efficiency mode, the car changes air con mode from Eco to On. I want it to always stay in Eco unless I change it myself. Has anyone found a setting for this?

2) The rear window defogger never stays on long enough to clear the window. I found the Adaptation channel with OBDEleven and I was surprised to see it's already set to 10 minutes - mine seems to turn off after about 5. I did notice however that there's also a shut-off temperature setting in that channel so maybe that's the cause. It's currently set to 35 degrees. Does anyone know what temperature I could safely increase it to?

Cheers
 

cuke2u

Registered User
Why don't you pm DJAlix? Yes you are correct the rear demister is temperature dependant, possibly also outside temp as well, I would be wary about changing it.
 

pierreluigi88

Registered User
Why don't you pm DJAlix? Yes you are correct the rear demister is temperature dependant, possibly also outside temp as well, I would be wary about changing it.

I thought doing an '@' would be better as it keeps any response public and so may be of use to someone else.
 

SimonAshley

Registered User
Mine does this also!

Old A4 seemed to clear much quicker and stayed on until window was clear!

New A5 on cold mornings seems to take forever to clear and often turns off before it's clear!

Probably going to mention it to Audi when I go in.
 

DJAlix

VAG Car Coding™ Limited
Site Sponsor
VCDS Map User
Gold Supporter
VAG Can Professional
ODIS (Offboard Diagnostic System)
I have a couple of questions around this subject - @DJAlix could you possibly help?

1) When changing drive select away from Efficiency mode, the car changes air con mode from Eco to On. I want it to always stay in Eco unless I change it myself. Has anyone found a setting for this?

2) The rear window defogger never stays on long enough to clear the window. I found the Adaptation channel with OBDEleven and I was surprised to see it's already set to 10 minutes - mine seems to turn off after about 5. I did notice however that there's also a shut-off temperature setting in that channel so maybe that's the cause. It's currently set to 35 degrees. Does anyone know what temperature I could safely increase it to?

Cheers
Not sure about 1). I have my A3 in Individual, with no Efficiency settings, and my Climate Control remains in ECO. 2) Yes there are timers and Temperature Cut-offs that are set and that can be changed. Never had a reason to test any of this however so let us know how you get on lol
 

pierreluigi88

Registered User
Not sure about 1). I have my A3 in Individual, with no Efficiency settings, and my Climate Control remains in ECO. 2) Yes there are timers and Temperature Cut-offs that are set and that can be changed. Never had a reason to test any of this however so let us know how you get on lol

Cool, thanks for coming back. I’ll update if I solve point 1, and don’t think I dare change the temp setting in case it causes the car to ignite!
 

cuke2u

Registered User
Not sure about that temperature setting as I doubt if the rear window would ever need to get to about +10 degrees. 35 sounds far to high to me..
 

Jsmills

Registered User
I have a couple of questions around this subject - @DJAlix could you possibly help?

1) When changing drive select away from Efficiency mode, the car changes air con mode from Eco to On. I want it to always stay in Eco unless I change it myself. Has anyone found a setting for this?

2) The rear window defogger never stays on long enough to clear the window. I found the Adaptation channel with OBDEleven and I was surprised to see it's already set to 10 minutes - mine seems to turn off after about 5. I did notice however that there's also a shut-off temperature setting in that channel so maybe that's the cause. It's currently set to 35 degrees. Does anyone know what temperature I could safely increase it to?

Cheers

Maybe if you don’t run the climate in ECO you might not need the rear heater so much....

The only time mine needs use is if it’s icy outside.

Just an idea :footy:
 

pierreluigi88

Registered User
Maybe if you don’t run the climate in ECO you might not need the rear heater so much....

The only time mine needs use is if it’s icy outside.

Just an idea :footy:

Hehe, I was waiting for someone to say this :) I'll give that a try but still, on all cars prior to this one I used to keep the aircon off unless it was summer, and the rear defoggers would always clear on 1 click, even with Audis. First world problems eh?!
 

cuke2u

Registered User
Hehe, I was waiting for someone to say this :) I'll give that a try but still, on all cars prior to this one I used to keep the aircon off unless it was summer, and the rear defoggers would always clear on 1 click, even with Audis. First world problems eh?!
I hope you know that is the wrong way to use the CC in the A4, or any car. Climate is designed to be left on all the time as if they are not then you could be causing damage as the fluid contains lubricant for the compressor bearings. Same goes for air con and recommendation is that they should be used for at least 20 mins each month..
 

pierreluigi88

Registered User
I hope you know that is the wrong way to use the CC in the A4, or any car. Climate is designed to be left on all the time as if they are not then you could be causing damage as the fluid contains lubricant for the compressor bearings. Same goes for air con and recommendation is that they should be used for at least 20 mins each month..

Yes, that's why I leave it on but I just want it to stay in Eco. In previous cars I used to run it once a week to lube everything up.
 
Top