Changed my interior and license plate light bulbs to LEDs.

xnox202

Registered User
A little update:

DSC01206.jpg

DSC01207.jpg

DSC01208.jpg

DSC01189.jpg

DSC01190.jpg

DSC01191.jpg

DSC01192.jpg

DSC01193.jpg

DSC01194.jpg

DSC01197.jpg

DSC01199.jpg

DSC01200.jpg

DSC01202.jpg

DSC01204.jpg

DSC01188.jpg


Interior lamps are from my local autostore. Pretty nice, lots of LEDs and very bright. Blue/white-ish looking. As for the license plate, did the trick with resistors on each bulb (150 Ohms) on Lucid Leds. Purple/white-ish looking.. kinda matches the front DRL LEDs I supposed.

:beer:

I can't wait till it's night time so I can take pictures of how they would look like in the dark. :D
 

S3 BUH

Registered User
looks really smart mate great pics , like the glove box LED very useful :icon_thumright:
 

V16

Registered User
definitely looks better! i hate the standard light colour. can u tell me the size of the leds in the glove box and boot?
 

BOSSS3

Registered User
Looks very neat bud! :icon_thumright:

Shoud come like that from the factory!
 

xnox202

Registered User
Glove box and boot are the same as this one:

gti_wedge_bulb.jpg


And, don't get the Lucid Leds! Somehow, mine turned really deep blue after a 20 minute drive. I was about to admire it and take a peek after I parked when I found that out. Going to change the LEDs as of the interior. Hope it works well.

Cheers everyone for the comment. Yes! These LEDs should had come stock on these cars. It really sports an "exclusive" feeling while you're in it. :D
 

xnox202

Registered User
Some night time shots. Notice the rear license plate lamps (By Lucid Leds) are really blue.

DSC01221.jpg

DSC01219.jpg

DSC01218.jpg

DSC01215.jpg


Not the best camera, but you get the idea. Going to change those Lucid Leds so should match with everything nicely.
 

xnox202

Registered User
Swapped the Lucid Leds out. In with the new ones. The color matches perfectly as with the interior too.

DSC01239.jpg


The best place to be:

DSC01246.jpg


:thumbup:
 

smudge_don

Registered User
Great work bud, i must get round to doing this at some point
 

Ash187

Registered User
VCDS Map User
Gold Supporter
That looks really nice! you must be very chuffed!

I want to do this on my sportback but have no idea where to get the LED's from, i want ones that i can just swap over and not have to put resistors on. any ideas guys? (im not good with soldering)
 

Ash187

Registered User
VCDS Map User
Gold Supporter
I know this is a real old thread but i want to bump it as i am still wanting to do this kind of LED upgrade and have no idea where to start...
Can anyone help me out?
 

WelshWoody83

Registered User
Ive been wanting to do this too just to have a crisper white light than the standard. I havent ordered any yet but was looking on ebay and saw these...
ULTRA WHITE INTERIOR LED AUDI 80 90 100 A3 A4 A6 A8 GT on eBay (end time 17-Jan-11 00:24:36 GMT)

I sent a message about whether you would have to solder resistors on and this is the reply I had...
Hi,

We do not recommend placing resistors on interior LED's, It literally can depend on the vehicle as to how it will function with the LED's. As long as the length of the bulb is correct we would expect it to be suitable :)

Kind Regards
Matt
24/7 Customer Support Team


But I read it as, try it, if they dont work then tough and havent bothered.
 

tku

Registered User
Another one bites the dust.

Just put some in that I got from a shop and they look the nuts but unfortunately a fault has shown up! Argh so gutted, guess il be changing them back tomorrow.
 

tku

Registered User
Anyone know if there's any side effects to driving around with the bulb fault?. I kinda love the lights sigh.
 

Smoothie

Registered User
thought about doing this before, looks excellent, i've just done the number plate for now though
 

tku

Registered User
What bulbs you got smoothie?

My car is a 2010 S3. Stupid DIS is lighting up. I just need bulbs that don't need tampering with I.E resistors etc cos I'm a dumbass.
 

Iain 750

Registered User
The ones i have are ready to go but apparently the dis system is different in the newer a3's and is more sensitive..
 

tku

Registered User
And yeah I read that thread already Iain. Cheers mate. However I know us MY10 peeps are having trouble finding a pair that works with no errors!
 

tku

Registered User
Indeed they are. I spoke to a guy who had them on his 54 plate a3 ad thought I would copy and went to same shop but unfortunately it was an epic fail.
 

Christer

Engage the beige!
Looks great mate! Changed all the interior lights on mine earlier this week!

And I just spotted my next mod! :D
 

Smoothie

Registered User
What bulbs you got smoothie?

My car is a 2010 S3. Stupid DIS is lighting up. I just need bulbs that don't need tampering with I.E resistors etc cos I'm a dumbass.

i cant remember the exact bulbs mate, scottie off here recommended them to my and they've worked perfect, i know about the MY10 problems though as ive had a few guys asking me about them in that same position

sorry bud - hopefully someone finds a plug/play solution soon
 

Lee_R

Registered User
Just bought some off ebay, the ones in the other link that smoothie bought. Fitting them was a piece of cake, turned the lights on and neither worked, got the bulb warning. So i swapped them around the other way and still nothing, no lights, just the warning!

No idea why they dont work, my cars an 04. So i put the old ones in and gave up. However the old ones dont work either now and i have a bulb warning

i give up on these sort of mods, no idea what do do now!! FFS!!!
 

munchkincoupe

Registered User
I've got the same problem as you now Lee - mine is an 04 and lights worked before - tried the LED bulbs - didn't work in any direction - swapped them back and original lights don't work now either - great!
 

khalil

Registered User
Just bought some off ebay, the ones in the other link that smoothie bought. Fitting them was a piece of cake, turned the lights on and neither worked, got the bulb warning. So i swapped them around the other way and still nothing, no lights, just the warning!

No idea why they dont work, my cars an 04. So i put the old ones in and gave up. However the old ones dont work either now and i have a bulb warning

i give up on these sort of mods, no idea what do do now!! FFS!!!

had similer problem, just wondering when you did put the leds in you did switch the engine on??
mines is at 04 too and i had the same problems like you until a switiched the engine on, also another thing is that make sure the connectors on the blub holders are touching the circuit in the car, maybe straighten them a little with some pliers, i did
 

Lee_R

Registered User
had similer problem, just wondering when you did put the leds in you did switch the engine on??
mines is at 04 too and i had the same problems like you until a switiched the engine on, also another thing is that make sure the connectors on the blub holders are touching the circuit in the car, maybe straighten them a little with some pliers, i did

Yeah tried it ignition off and on, then turned the car on too, still nothing. Also tried locking the car up and starting a fresh but nope, nothing, I had a look at the connections and they are pretty straight anyway. My hands are freezing out there and the screwdrivers isnt the easiest to work with due to angle so i'll have another play tomorrow!
 

khalil

Registered User
ye i know what you mean mate it is cold out there,another way which you can try is get 2 wires and attach them to the bulb holder, that way when you connect the ends to the boot circuit you can easly swap the wires around to see if its works, i tried that way few weeks back when i did it on my brothers car,
hope you sort it out mate
 

evapor8

Registered User
I'm still hoping that someone will come across some numberplate LED's that don't throw up the errors for 2009/10/11 cars.

Until then, I'll wait.

Chris
 

Diamond

Registered User

tku

Registered User
Just bought some resistors today. Gonna give it a shot tomorrow and see how it goes!
 

nelson19uk

There's no poke without smoke!
I did this in my A4. I bought some led's from superbrightleds.com in the US and some off of ebay. The ones from Superbright were the best but the ebay ones were crap. One of them flickered all the time and another just didn't work at all. In my opinion you get what you pay for when it comes to led's.
 
Top