1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Central locking problem after cruise control retrofit

beefys Sep 17, 2018

  1. beefys

    beefys New Member

    13
    1
    1
    Hi

    I have a 2010 A3 2.0TDI 140 Sportsback S Line. After having a friend retrofitting cruise control to the car my central locking via the key fob stopped working. The central locking works fine using the drivers door lock and the drivers door interior lock switch. The key shows the red LED when I press the buttons on the fob. I took it to someone who used VCDS and he said that he could not access the convenience module to recode the key, so that may be the problem. I also have an aftermarket head unit a XTRONS Satnav/DVD player. Before the retrofit of the cruise control the head unit used to turn off when I removed the key however now it stays on and I have to manually put it to sleep. From reading the forums on here it thought it maybe the control module and had a look in the rear driver side boot but the module is not there. Cam anyone help?

    BTW I have removed the cruise control and installed the original stalk back bit still have the same issues.

    Thanks in advance

    Sent from my SM-G955F using Tapatalk
     
  2. Avatar

    snack-media
    Advertisement


  3. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    30,460
    2,010
    113
    What coding did he actually do.
     
  4. Abi

    Abi Active Member

    338
    62
    28
    How was the cruise control coded? I also have that radio fitted and did the Cruise retrofit last month on my 2010 A3 140 tdi. Coded it myself via vcds with no problems at all. Sounds like a coding fault. Hopefully the original code’s was saved? If so revert them back and code the cruise properly.


    Sent from my iPhone using Tapatalk
     
  5. beefys

    beefys New Member

    13
    1
    1
    The coding was reverted back to what it was before the retrofit. He assured me that only 2 values were changed under section 16 and 17.

    The original values were screenshot before changing and this was used to revert back.[​IMG][​IMG]

    Sent from my SM-G955F using Tapatalk
     
  6. Abi

    Abi Active Member

    338
    62
    28
    Mmmm,
    My coding was done via long coding helper, module 1 and module 9 from what I can remember.


    Sent from my iPhone using Tapatalk
     
  7. beefys

    beefys New Member

    13
    1
    1
    I can only assume it's the control module itself. However I have no idea where it is and if it is even replaceable. I have only one key so I can't also do the self key coding if that would help the problem.

    Sent from my SM-G955F using Tapatalk
     
  8. Abi

    Abi Active Member

    338
    62
    28
    You can code keys in central electric’s module 9 under adaptation! My memory recalls


    Sent from my iPhone using Tapatalk
     
  9. beefys

    beefys New Member

    13
    1
    1
    We tried this. The problem isn't with the key itself. The VCDS can see the key and also acknowledges the key press. The issue is we can't save the new value because it can't communicate to the module. We checked the fuses in the engine bay and the side of drivers door bit all were fine.

    Sent from my SM-G955F using Tapatalk
     
  10. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    You might want to update your Vcd's cable if its genuine as it is 18.2.1 version they use now.
     
  11. Abi

    Abi Active Member

    338
    62
    28
    Not sure what my vcds version is, can’t check till home fr work later.


    Sent from my iPhone using Tapatalk
     
  12. Avatar

    snack-media
    Advertisement


  13. beefys

    beefys New Member

    13
    1
    1
    The photo shows the VCDS we used on the initial retrofit. When we changed the values back to how they were I had to pay someone to come out and do it as my mate was unavailable. I have contacted the person I paid and he has said he is using the latest version with an original RossTech cable.

    Sent from my SM-G955F using Tapatalk
     
  14. Abi

    Abi Active Member

    338
    62
    28
    How come values were changed in section 17 ‘instruments’ as I didn’t


    Sent from my iPhone using Tapatalk
     
  15. beefys

    beefys New Member

    13
    1
    1
    I'm not sure about the coding sections. I think my friend was following a step by step guide when he done it. But he has assured me many times that the only 2 values he changed was the 2 pics he took. When I paid for the coding to be changed back these 2 values were only changed.

    Sent from my SM-G955F using Tapatalk
     
  16. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    I take it you never took a pic or 2, off the pics the other guy did when he changed the coding back to what it was before you did the retrofit , as that could help .
    Did you do an Autoscan b4 you changed any coding .
    The guy you paid was he not able to tell you if the module you had in the car was capable off taken Cruise Control.
     
    Last edited: Sep 18, 2018
  17. beefys

    beefys New Member

    13
    1
    1
    The 2 pics are taken before the change. We used the same pictures to enter the original values back. I'm not sure if an Autoscan was carried out initially.

    Sent from my SM-G955F using Tapatalk
     
  18. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    I would get the guy you paid to come back and retrace what you tried to do and add the cruise control and see if he can recode for you as you have nothing to loose if he does an autoscan first as this will safe all coding b4 you change it
    Or you could seek the retrofitters from the site for a small fee to fix for you @Ash187 or @NHN
     
  19. Abi

    Abi Active Member

    338
    62
    28
    I could post you pictures of the the codes off my vehicle if you would like (being the same vehicle), but can’t do that till Thursday as my laptop is at girlfriends and cable is at mine.

    Regarding the software not communicating with the module, I’m no expert but all I can think of is the cable is no longer authorised, this can be checked by opening vcds and going to ‘options’

    Hope this helps


    Sent from my iPhone using Tapatalk
     
  20. beefys

    beefys New Member

    13
    1
    1
    Thanks for your help. Yes please can you send screenshots when you get a chance and I can compare mine. Is there anyone close to Birmingham that has VCDS that I can visit to get a Autoscan done?

    Sent from my SM-G955F using Tapatalk
     
  21. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    The Cable should be fine if its a genuine one , only need to plug into comp and update to the newest version 18.2.1
     
    Last edited: Sep 18, 2018
  22. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    Your car even tho the same age it would need to have all that he has in his ie ambient lighting , footwell lights etc for your code to help him , so best you send him pics off all the bytes and bits which will allow him to see what you both have and compare . Maybe PM him and get email addy
     
  23. Abi

    Abi Active Member

    338
    62
    28
    Yes I agree ‘sorry wasn’t thinking’ still learning about vcds, and coding


    Sent from my iPhone using Tapatalk
     
  24. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    Thats not a problem at least your trying to help the guy , everyday is a School day
     
  25. beefys

    beefys New Member

    13
    1
    1
    Have booked it for the weekend for VCDS will post the results here.

    Sent from my SM-G955F using Tapatalk
     
  26. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    If you have it booked in take your retrofit stuff and get the guy there to code for you , if he knows his way around vag he should be able to code for you or be able to tell you if it can be added
     
  27. beefys

    beefys New Member

    13
    1
    1
    I will do thanks.

    Sent from my SM-G955F using Tapatalk
     
  28. Abi

    Abi Active Member

    338
    62
    28
    My version is 16.80 unfortunately I can’t upgrade.....


    Sent from my iPhone using Tapatalk
     
  29. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    I used to have 1 off those 16.8 cables ( clone ) worked fine for a while then it started throwing up faults amd stupid me would go buy the sensors and find out later they never need changed so ended up buying the correct 1 and never a problem since
     
    Last edited: Sep 18, 2018
  30. Abi

    Abi Active Member

    338
    62
    28
    Mmmm...
    yes! bought off EBay about 3 years ago, only mainly use it to reset service intervals on my girlfriends and my A3 but have used it more on mine to activate cornering lights and other little tweaks plus cruise control most recently.


    Sent from my iPhone using Tapatalk
     
  31. Abi

    Abi Active Member

    338
    62
    28
    Never had a problem in 3 years with this one.


    Sent from my iPhone using Tapatalk
     
  32. Abi

    Abi Active Member

    338
    62
    28
    My last comment on here, as other peeps know more about this than me.

    I followed all the coding process step by step on the ‘Cruise Control retrofit guide’ thread on here and worked perfectly first time. Even with my vcds version!



    Sent from my iPhone using Tapatalk
     
  33. Avatar

    snack-media
    Advertisement


  34. beefys

    beefys New Member

    13
    1
    1
    Thanks for your help mate. I'll try the VCDS this weekend as said and see if it sheds any light on the matter.

    Sent from my SM-G955F using Tapatalk
     
  35. Abi

    Abi Active Member

    338
    62
    28
    Did you have any luck at the weekend?


    Sent from my iPhone using Tapatalk
     
  36. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,707
    786
    113
    I think this is going to be another one off the unfinished threads lol
     
  37. beefys

    beefys New Member

    13
    1
    1
    Hi

    Sorry about the late reply. Unfortunately couldn't get it diagnosed as the guy had some family emergency. I will update the thread when I have the readings. Might be this weekend

    Thanks


    Sent from my SM-G955F using Tapatalk
     
  38. Abi

    Abi Active Member

    338
    62
    28
    Did you get your car’s central locking sorted in the end?


    Sent from my iPhone using Tapatalk
     
  39. beefys

    beefys New Member

    13
    1
    1
    After a year got it sorted. The BCM module under the steering wheel was changed and connected it to vcds. Done a key adaption and now is working fine. Before this I did notice a few wires sliced in the driver door loom bit that didn't fix the problem. Was the BCM in the end.
     
    Abi likes this.

Share This Page