Boost playing up

Cbax

Registered User
Right hi guys, apologies in advance, my English skills arent the best so I'll try make this as clear as possible.

A basic description of my car, bought it standard and turns out its mapped as I fitted gauges and found it was boosting higher than stock, since buying it I've done a fair few mods to the car ready to bring it upto a "stage 2" figure (minus the fmic) I wont bother listing the mods.

The problem I'm having: so it's temperamental as far as I can tell, when I'm driving and go to accelerate fairly hard my boost spikes to over 2bar, sometimes hearing some sort of chatter from the engine bay, I have to lift off and slowly accelerate back on again to get boost. This happens most times.

Other times the boost gauge gradually rises but cant feel the power change, sort of feels like it's leaking out the system and leaving me with a flat feeling with no boost

A few times before but not for a while now its felt like it's gone into limp mode, not boosting over somewhere like .4 bar.

Apart from that the car runs sweet, bit rough on idle but heard it's normal for these engines.

I've had it smoke tested and it showed no leaks! Ran diagnostic through it and it's not pulling any codes.

Had a few suggestions as to what could be causing but was hoping someone on hear may have had this issue in the past and know where to start? some say it's the map, others say the lamber sensor, others say different.

Getting on my tits now so any help would be greatly appreciated!

Thanks guys
 

badger5

www.badger5.co.uk
Site Sponsor
what engine code?
n75 unplugged does it do consistent boost?
 

Cbax

Registered User
n75 has my bet on it for being faulty


So I've replaced the n75 with a new genuine one and it's fixed the issues but now on cold starts in struggles to start, really lumpy and revs drop that much the car feels like its gunna implode. Have ideas of the top of your head ? Haha
 

badger5

www.badger5.co.uk
Site Sponsor
Possibly yeah feels like it could be, its only started doing it since changing the n75 cant be linked can it ?
only in that if its doing more boost now, its exposed the pumps inability to maintain pressure...
but without logging its of course "internet advise" only.............
 

Cbax

Registered User
only in that if its doing more boost now, its exposed the pumps inability to maintain pressure...
but without logging its of course "internet advise" only.............

Ah right okay, should be getting vcds installed this weekend is there anything on there that will tell me ?
 

Cbax

Registered User
Think I spoke too soon, the boost feels loads better but still had the occasional same issue
 
Top