Bit of advice before Xmas travels?

Gussy

Registered User
Hey Guys,

I'm travelling from Inverness to Aberdeen soon but my Coolant light keeps coming on when i start my A3 sportback tdi 1.9. I checked the coolant level and its fine and not frozen (we're gettin -10 pretty much every night). After 3-5 mins on idle the coolant light goes off and all seems well. Is this anything to worry about?

Hope someone can help

Cheers in advance, Gussy
 

PaulTheo

Registered User
If its only the level light and you know the level is ok you are no worse off than a car without a level light. I would just check the level daily for piece of mind.
 

mike foster

Fossie
VCDS Map User
There is a sensor inside the header bottle which often causes problems.

Take the sensor out and clean the two probes with a brillo pad or similar and it should be ok. These two probes work by passing a current between each other and if they get a bit corroded then don't report properly and throw up an error.

As said above, if you are sure you are not losing coolant then it is nothing to worry about and a quick clean will sort it.

Have a good trip
 

Gussy

Registered User
Thanks for the replies guys. If the probes you are talking about are actually in the water they can't be removed. I took the plug off and inspected the metal connectors in there and all looked fine!

If this persists do you know what i'll have to change and if so how much roughly? (not a good thing to be thinking about before xmas!)

Thanks again guys, Gussy
 

mike foster

Fossie
VCDS Map User
If you're sure you can't remove the sensor then it must come with the expansion tank !

Part number is :-1K0 121 407 A and is priced at about £15 - looks very cheap I must say, especially if it has the sensor built in. I can't seem to find a separate item for the sensor alone so maybe it is all-in-one !

Good luck
 

Gussy

Registered User
If it helps others I topped up just over max while warm.I used g12++ and all seems well.
 
Top