Beeping under hard acceleration

ohmyaudi

Registered User
I've noticed recently that occasionally when I floor it there will be a long quiet beep that seems to come from the engine bay. Anyone experienced this?
 

ohmyaudi

Registered User
I'll try and get one. It's quite hard to as it doesn't happen all the time. I can't work out the parameters that cause it to do it.
 

AlS3BE

Registered User
Do you have a dash cam? Noticed mine beeps if g-force exceeds a certain level.
Other thing that beeps is the speed limiter you set in the MMI. Someone might have changed it for a laugh.
There’s not many electronic beeps in a car. Only other thing is parking sensors.
Could it be a boost pipe or vacuum pipe that leaking and creating a whistling type sound under hard acceleration?
 

ohmyaudi

Registered User
Do you have a dash cam? Noticed mine beeps if g-force exceeds a certain level.
Other thing that beeps is the speed limiter you set in the MMI. Someone might have changed it for a laugh.
There’s not many electronic beeps in a car. Only other thing is parking sensors.
Could it be a boost pipe or vacuum pipe that leaking and creating a whistling type sound under hard acceleration?
Nah no dash cam. There's a speed limiter?! Haha didn't even know.

Yeah I thought potentially it could be a whistling sound from a pipe as I recently installed an induction kit. I've checked all piping and seems tight. Is there an easy way to test for leaks?

I'm also suffering from quite bad rev hanging as well. It could all be related. I may just revert back to stock airbox at this rate.
 

AlS3BE

Registered User
Nah no dash cam. There's a speed limiter?! Haha didn't even know.

Yeah I thought potentially it could be a whistling sound from a pipe as I recently installed an induction kit. I've checked all piping and seems tight. Is there an easy way to test for leaks?

I'm also suffering from quite bad rev hanging as well. It could all be related. I may just revert back to stock airbox at this rate.

It’s not a speed limiter but more a warning. Say you set it to 60mph every time you go over that the MMI will beep and the dash will show a warning.

As for your leak it’s not as easy to test unlike a tyre puncture where you spray soapy water and it bubbles up. I can’t think of how you could test this without having to pressurise the intake.
If all the connections are tight it could be a crack or break in the rubber hoses. Other thing is the pcv was common problem on some of these
 

MikeParkin

Registered User
A garage can do a “smoke” test to see if there is a leak.

I would revert to stock see what happens and work from there.
 
Top