1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B7 RS4 Driver heated seat issues

Steve_T_RS4 Feb 25, 2018

  1. Steve_T_RS4

    Steve_T_RS4 New Member

    3
    0
    1
    Hi,

    I’m new to the forum and I have owned a B7 RS4 for 3 years now and the drivers heated seat has never worked.

    So today I took the opportunity to investigate this. The car had the seats stolen and then replaced by the previous owner so my first assumption that was maybe the wiring had been damaged.

    I have had the seat up and there does appear to be a voltage across the pins on the green connector but they don’t seem to change when adjusting the heat level.

    I have been searching the internet today to try and find out what pins on the green plug I should get a voltage across when the seats are set to heat. But unfortunately, I have been unable to find a definitive answer.

    Does anyone know of a way to test this to determine the issue? before I start looking at replacing the element in the seat.

    Thanks
    Steve
     
  2. Avatar

    Google AdSense Advertisement


  3. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,431
    3,793
    113
    have you tried the passenger seat to see if it is both on the blink or just drivers side.
    the same setup is used in A4/s4 and rs4 for heating seats so you'll get replies from this forum but you may get more specific help from the RS4 section aswell.
    i'll move you over to the B7RS4 section.
     
  4. Steve_T_RS4

    Steve_T_RS4 New Member

    3
    0
    1
    Sorry should have mentioned that. The passenger seat works perfectly. I have checked the fuse but there is only one fuse that does both seats.
     
  5. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,431
    3,793
    113
    this may seem like a long way round but it may illuminate several things at once, as both seats will be wired up the same way for heating function, why not remove both seats and try the passenger seat connected to the driver side connections.
    don't fix it in , just connect it up for the heating function and see if it gets warm, if not then it illiminates the drivers seat to start with and work back from their, you could try the drivers seat hooked up to the passenger side and do the same, see if it gets warm.
    Just a case of illuminating as much as possible first and then working from that point, just a thought chap as a starting point and I maybe wrong...

    good luck
     
  6. Steve_T_RS4

    Steve_T_RS4 New Member

    3
    0
    1
    Not a bad call. Thanks i will try that. If the element has gone can it be replaced and is it a specialist job?
     
  7. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,431
    3,793
    113
    I couldn't say chap, never had to look that far into the seat heating.
     
  8. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,431
    3,793
    113
    the plug that carries the heating circuit is an 8 pin block plug, that's where you should be checking , not sure if it is the same for the comfort recaro's and wing back's but very likely.

    upload_2018-2-25_18-22-7.png
     
  9. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,431
    3,793
    113
    upload_2018-2-25_18-29-37.png
     
  10. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,431
    3,793
    113
    upload_2018-2-25_18-33-35.png


    upload_2018-2-25_18-34-24.png
     
  11. flylife2k

    flylife2k New Member

    20
    5
    3
    Digging up an old'sh post but can anyone confirm like the oem part pics above if the heated wingbacks have elements for the top (back) and bottom derrièr section are both heated or just the bottom? Clearly mine is just heating the bottom so either the back element is gone or that's just how they are
    Thanks chaps
     
  12. Avatar

    Google AdSense Advertisement


  13. mikep99

    mikep99 Active Member Team Phantom Audi RS4

    255
    116
    43
    Pretty sure it's just the base that's heated.
    I've never noticed my back warming up when I've had mine on.

    Mike

    Sent from my PRA-LX1 using Tapatalk
     
  14. flylife2k

    flylife2k New Member

    20
    5
    3
    Okay thanks for confirming Mike, one less thing for me to sort :icon thumright:

    Tiff
     

Share This Page