1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Audi Sound System - subwoofer query

Pganders Dec 4, 2018

  1. larbel

    larbel Registered User

    975
    720
    93
    Here's mine... SW 0727... The B&O fix version in US is 1196, no idea why it's now going backwards??

    IMG_0379.jpg
     
  2. Avatar

    snack-media
    Advertisement


  3. AlS3BE

    AlS3BE Registered User

    3,418
    2,037
    113
    In vcds there’s a module for information electric (5f) and I have a module for sound system(47)
    Are you guys looking at the wrong module for software number/revision to get your sub control?
    Just a suggestion
     
  4. larbel

    larbel Registered User

    975
    720
    93
    *** doesn't have 47, it's all 5F... And from my understanding, the fix is 5F firmware update...
     
  5. AlS3BE

    AlS3BE Registered User

    3,418
    2,037
    113
    Oh well. Ignore me. Barking up the wrong tree. :wink:
    Was looking at mine which has the b&o.

    If there are people with the same firmware and some do and don’t have sub control then it must be in something else.
    The firmware drives the main unit and all modules attached must have their own driver/software and possible firmware.
    Could it be a driver issue for the sub/amp?
    I’m just thinking how I would go about it in a windows based pc. Easier to think about it like a pc. If it’s not firmware then it’s driver/software issue or just complete incompatibility.
     
  6. Pganders

    Pganders Registered User

    70
    12
    8
    I wonder if it’s any different if you speccd *** as an option and paid for it. Mine came standard as a 2019 MY upgrade for the S-line spec. Certainly if I’d ordered and paid for it I would be more than miffed.
     
  7. HertS3

    HertS3 Registered User

    1,160
    372
    83
    @DJAlix what is the cost of retrofitting *** to the basic setup please and where are you based?
     
  8. larbel

    larbel Registered User

    975
    720
    93
    *** uses the built in amp in 5F, that's why it doesn't have module 47, and we're still waiting for @A3saloon sound setting picture to confirm if indeed *** can even have sub control in FL. But as far as I know, it's the 5F firmware update that fixes for B&O.
     
  9. Azz

    Azz Registered User

    127
    16
    18
    simple fix, MMI update for free from Audi anywehre, i asked them when i did my service about it , mine didnt have the Subwoofer control. now it does. the B/O system is booming
     
  10. Pganders

    Pganders Registered User

    70
    12
    8
    I’m assuming from your comment that you have B&O and not ***. Different systems and as I’m beginning to gather B&O is fixable but *** is a different matter for which the posters with *** have yet to see any hard evidence of a fix.

    @A3saloon can you put us all out of our misery??
     
  11. AlS3BE

    AlS3BE Registered User

    3,418
    2,037
    113
    Right I think this is getting a little muddled up here.

    So I think there people are bringing in b&o and potentially other variants into this. Think we should look at it more logically and concentrate on the ***.

    This is a fl problem so keep the pfl stuff out.

    So assuming FL with ***.

    variants in my head should be the following.

    MMI low with ***
    Do these people have the sub control? Software version number of those who do and don’t.

    MMI high with ***
    Same again, do these folk have sub control and software version number.

    MMI high with Audi connect with ***
    Again, sub control and software version.

    There might be other variants or combinations with things like Audi phone box/antenna booster, wireless charging etc
    The thing is it could be one of these add on parts that conflicting with something so getting a list of possible combination should help find the problem and find a solution.
     
  12. Avatar

    snack-media
    Advertisement


  13. Pganders

    Pganders Registered User

    70
    12
    8
    Good intervention AIS3BE to bring some order to this.

    My details are:
    • S-line
    • Build date Sept 2018,
    • MMI low with ***,
    • No subwoofer adjustment,
    • software version 0235,
    • no other options.
     
    AlS3BE likes this.
  14. ivelliosy

    ivelliosy Registered User

    36
    0
    6
    Hi guys, any update on topic?
     
  15. DaveLympo

    DaveLympo Registered User

    7
    2
    3
    Hi, just noticed this thread, i`m having the exact same issue i have a late 2019 model A3 black edition with the audi sound system with a sub in the spare wheel well. There is no adjustment for the sub but the manual says there is, also there is no fader to rear speakers only front or all manual says there is. I wonder if dealership will update firmware?

    Its booked in with dealership to investigate next week.
     
  16. Azz

    Azz Registered User

    127
    16
    18
    My 66 plate was in the same boat no subwoofer control.

    I read about a MMI update and audi did this in 2018, you have to tell them check for MMI updates etc.. Now I have the subwoofer control and it sounds amazing
     
  17. DaveLympo

    DaveLympo Registered User

    7
    2
    3
    So Audi dealership updated it for you? Did they charge? which software version do you have now after update?

    Thanks
     
    Azz likes this.
  18. Azz

    Azz Registered User

    127
    16
    18
    Yeh they updated it foc don't see why there would be a charge for it.
    Il check tomorrow
     
    DaveLympo likes this.
  19. Phazer

    Phazer Registered User

    69
    26
    18
    The appearance or not of things like DSP/Subwoofer control has nothing to do with firmware which is why two devices running the same software can show different options. Also, on the number going "backwards", the US and Europe always run different software so you can't cross flash, there may be hardware differences too based on radio reception amongst other things. Numbers being different between European devices will be down to the hardware being different. There's a number of combinations on the A3.

    Menu/output options is down to the parameterisation of the units. This can't be done with VCDS. When I did my S1 I used VCP to re-parameterise and enable Audi Sound System. First one enables the internal amplifier, the second tells the unit what speakers are supported and what options are supported. On my unit, enabling the sub also sorts the menu.

    As I understand it, that's not the case on the facelift A3 and at the moment I don't think anyone has the parameterisation for the sub menu. It may be possible to read out from a working car but that parameterisation will only be good for the same hardware.
     
  20. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,697
    5,120
    113
    Not true, in this case it’s 100% firmware and not parameters as I tested with a number of vehicles. Now if you wanted to retrofit Audi Sound System and B&O then parameters are involved.
     
  21. Phazer

    Phazer Registered User

    69
    26
    18
    Ahhh ok thanks for that. Interesting. Why on earth do they have so many ways of doing the same things :D
     
  22. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,697
    5,120
    113
    They don’t. The no sub control for factory fitted systems was by design. Owners had been complaining about rattles and vibrations from the Rear of their cars and the root cause was “found” to be the subwoofer but instead of padding out and securing trims etc the official fix was.... “remove the a ability to turn up the bass from new cars” and thus remove the issue lol.
     
  23. Phazer

    Phazer Registered User

    69
    26
    18
    I meant across the platforms but anyway, awesome "fix". It's quite clever but a bit naughty really.
     
  24. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,697
    5,120
    113
    Different platforms use different control modules and technology etc. Using the MQB platform for example, facelift cars basically did away with long coding in central electric. Things evolve and move on.
     
  25. plop808

    plop808 Registered User

    1
    0
    1
    Thanks for clarifying this. No we actually know why they removed the option.
    Do you know any way of manually adjusting the sub-woofer levels? So not with the software but with hardware adjustments?

    PS.: I thinks this is a lazy 'fix'. They should've kept the menu option but add a warning or something instead.
     
  26. Azz

    Azz Registered User

    127
    16
    18
    My version is 0213 so there is defo an update. Seen some other comments where there's a newer updates 0235

    I got mot this week with Audi so will ask abktj further updates.
     
  27. DaveLympo

    DaveLympo Registered User

    7
    2
    3
    my A3 is in the dealership as I type this, one of my issues amongst a few other niggles was no sub adjustment on MMI, the tech told me basically it doesn't apply to the Audi music system, only the higher spec versions ie bose and b&o. which kinda makes sense. He said there's no update that would produce sub control. And thats from a main dealer.
     
    Azz likes this.
  28. DaveLympo

    DaveLympo Registered User

    7
    2
    3
    mine is the 0235 version still no sub control
     

Share This Page

Do Not Sell My Personal Information