Audi s3 stage 2+ down on power

jonathon 242

Registered User
Hi I’m new to the group. Hopefully you can help me with the problem I’ve got. I have a Audi s3 stage 2 plus. When I got it mapped last year it was running 360bhp but now it’s lost power, its around 300bhp. no fault codes. Seems to be running fine and boosting as it should do. Any advise would be great. Thanks John
 

S.

Save the manuals
What map do you have?
 

S.

Save the manuals
With these engines can be anything really. Recently i found out that missing dip stick seal caused power loss. Did you check pcv and hose?
(I'm also hunting for a cold start issue on mine once up to temperature runs like a beast and the car had major work done few months ago).
 

paddy

Registered User
If you know it's dropped to 300 didn't the guy that dyno'd it offer any clue ?
 

jonathon 242

Registered User
With these engines can be anything really. Recently i found out that missing dip stick seal caused power loss. Did you check pcv and hose?
(I'm also hunting for a cold start issue on mine once up to temperature runs like a beast and the car had major work done few months ago).
Yeah had a new dipstick and pcv valve a few months ago and the cars been smoke tested all looks fine.ive been over everything twice I thought it would bring up the eml light or something but no it drives spot on.not sure what to do now
 

jonathon 242

Registered User
If you know it's dropped to 300 didn't the guy that dyno'd it offer any clue ?
Haven’t had It on the dyno yet a guy I spoke to said to divide the mass air flow g/s reading by 0.8 and that would give you the bhp.at maximum rate it was 240.30 g/s which works out to 300bhp
 

paddy

Registered User
I think my first move might be to get it on the rollers, failing that i would see if jabba will re install the map so you know you are starting from a good base.
 

jonathon 242

Registered User
I think my first move might be to get it on the rollers, failing that i would see if jabba will re install the map so you know you are starting from a good base.
Yeah think I’ll get it booked in an see what that brings up and take it from there
 

voorhees

Moderator
Staff member
Moderator
Haven’t had It on the dyno yet a guy I spoke to said to divide the mass air flow g/s reading by 0.8 and that would give you the bhp.at maximum rate it was 240.30 g/s which works out to 300bhp
I take it you have upgraded your intake so that formula wouldn't work as the diameter where the sensor is has changed size so airflow isn't measured accurately.
 
Top