1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audi S3 Flatspot between 4 & 5000 RPM

Naoise Enright May 3, 2018

  1. Naoise Enright

    Naoise Enright New Member

    4
    2
    3
    Hi All

    I have a lovely 1999 Audi S3 and when I rev it there is a very notable flatspot between 4 & 5000 rpm. After that he powers on again and flies through the red line. It over revs too when I accelerate hard and when I change gear at around 5,500 revs the engine over revs again. A breather hose was replaced a year ago or so by Audi main dealer but that was on inspection and not via the ecu. The ecu did not show up any faults so I’m a bit lost. Any direction would be great appreciated. Regards Naoise
     

    Attached Files:

  2. Avatar

    Google AdSense Advertisement


  3. S3YEP

    S3YEP New Member

    17
    8
    3
    Hi, I have a 2001 (AMK) S3 and have had numerous problems including issues with the revs. I have learned that air leaks can cause allsorts of issues. I would get a smoke test to make sure there are no leaks, as over time I,ve had N249 delete, various pipes replaced and the N75 valve replaced due to leaks, none of which showed up on a VAG scan. Good luck

    Sent from my SGP712 using Tapatalk
     
    Tj 0785 likes this.
  4. Solberg

    Solberg Active Member

    305
    53
    28
  5. S3YEP

    S3YEP New Member

    17
    8
    3
    Hi, I had to replace the clutch pedal switch, the problem for me was not a flat spot, but the rev's would "hang" when the pedal was depressed and not "drop" hope this helps. Regards LeRoy

    Sent from my SGP712 using Tapatalk
     
  6. Naoise Enright

    Naoise Enright New Member

    4
    2
    3
    Thanks guys, to the three of you I really appreciate this and great to see the passion for this wonderful car. I’ll definitely look into each and everyone of your comments and revert back. Thank you so much again. Regards Naoise (Donegal Ireland)
     

Share This Page