Audi A6 Allroad Auto Gearbox Slipping / multi function gearbox switch?

Antony Kokes

Registered User
Hi Guys I'm really trying to keep this beauty on the road. My problem is that the auto gearbox is slipping. I was advised by Audi specialist to change transmission fluid, gasket & filter. I finally got around to getting it done. It cost me £165 which I was happy to pay as I had been quoted £300+ but unfortunately this has not cured the problem. It was a local garage that change the fluid & I took it back for further examination & they said they 95% sure it's the multi function gearbox switch 5% it might not be. They said that the Auto box has two types of switch an 8 pin & a 10 pin version. One is £199 & one is £369. They can not tell me which switch it is till the gearbox is opened & also the part can not be returned if it turns out not to be the switch. I was wondering if anyone has had this problem or might have some knowledge of the Auto gearbox or any general advise?
Many thanks
 

simo79

Registered User
There is a how to on the rs6 forum on how to replace the multifunction switch without dropping out the box, a bit fiddly though.

I assume this is zf5hp24a box.

Another possibility could be the level the fluid was topped up in. The car has to be level and the fluid warmed up to 40c (so needs to be done with engine running). With the filler open pump in fluid until it’s dripping out the select all the gears, top up as required until the fluid drips out from the filler areas around every couple of seconds.I’m sure there is a how to on the rs6 forum.

Is it slipping in all the gears or just first?







Sent from my iPhone using Tapatalk
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
Hi Guys I'm really trying to keep this beauty on the road. My problem is that the auto gearbox is slipping. I was advised by Audi specialist to change transmission fluid, gasket & filter. I finally got around to getting it done. It cost me £165 which I was happy to pay as I had been quoted £300+ but unfortunately this has not cured the problem. It was a local garage that change the fluid & I took it back for further examination & they said they 95% sure it's the multi function gearbox switch 5% it might not be. They said that the Auto box has two types of switch an 8 pin & a 10 pin version. One is £199 & one is £369. They can not tell me which switch it is till the gearbox is opened & also the part can not be returned if it turns out not to be the switch. I was wondering if anyone has had this problem or might have some knowledge of the Auto gearbox or any general advise?
Many thanks
Can you describe the " slipping "
 

Antony Kokes

Registered User
There is a how to on the rs6 forum on how to replace the multifunction switch without dropping out the box, a bit fiddly though.

I assume this is zf5hp24a box.

Another possibility could be the level the fluid was topped up in. The car has to be level and the fluid warmed up to 40c (so needs to be done with engine running). With the filler open pump in fluid until it’s dripping out the select all the gears, top up as required until the fluid drips out from the filler areas around every couple of seconds.I’m sure there is a how to on the rs6 forum.

Is it slipping in all the gears or just first?







Sent from my iPhone using Tapatalk
Hi thank you for your response. When I turn on the ignition & select drive then move the gear stick across to manual mode it shows up as in gear 4 in the LCD dashboard display I would have thought it should be Gear 1. The mechanic told me to try this to show how the switch is possibly at fault.

When I start the car & drive it pulls away ok at first & goes through the gears when in drive at low revs but as soon as I apply any acceleration over 2000 rpm (like when going up a hill) the car just seems like it slips out of gear & revs just shoot up (like a manual gearbox would sound/act if you put it into neutral instead of gear & tried to drive).

When I have been taking it to the garage or wherever I have been using it in manual & when it starts to slip I have been knocking it up a gear.
This only gets you so far then the autobox goes into limp/safe mode
 

Antony Kokes

Registered User
Can you describe the " slipping "
Hi thank you for your response. When I turn on the ignition & select drive then move the gear stick across to manual mode it shows up as in gear 4 in the LCD dashboard display I would have thought it should be Gear 1. The mechanic told me to try this to show how the switch is possibly at fault.

When I start the car & drive it pulls away ok at first & goes through the gears when in drive at low revs but as soon as I apply any acceleration over 2000 rpm (like when going up a hill) the car just seems like it slips out of gear & revs just shoot up (like a manual gearbox would sound/act if you put it into neutral instead of gear & tried to drive).

When I have been taking it to the garage or wherever I have been using it in manual & when it starts to slip I have been knocking it up a gear.
This only gets you so far then the autobox goes into limp/safe mode
 

Antony Kokes

Registered User
There is a how to on the rs6 forum on how to replace the multifunction switch without dropping out the box, a bit fiddly though.

I assume this is zf5hp24a box.

Another possibility could be the level the fluid was topped up in. The car has to be level and the fluid warmed up to 40c (so needs to be done with engine running). With the filler open pump in fluid until it’s dripping out the select all the gears, top up as required until the fluid drips out from the filler areas around every couple of seconds.I’m sure there is a how to on the rs6 forum.

Is it slipping in all the gears or just first?







Sent from my iPhone using Tapatalk
Hi thank you for your response. All the gears.
When I turn on the ignition & select drive then move the gear stick across to manual mode it shows up as in gear 4 in the LCD dashboard display I would have thought it should be Gear 1. The mechanic told me to try this to show how the switch is possibly at fault.

When I start the car & drive it pulls away ok at first & goes through the gears when in drive at low revs but as soon as I apply any acceleration over 2000 rpm (like when going up a hill) the car just seems like it slips out of gear & revs just shoot up (like a manual gearbox would sound/act if you put it into neutral instead of gear & tried to drive).

When I have been taking it to the garage or wherever I have been using it in manual & when it starts to slip I have been knocking it up a gear.
This only gets you so far then the autobox goes into limp/safe mode
 

simo79

Registered User
Are you sure it’s not going into limp mode. Do you get any beeps when you start the car


Sent from my iPhone using Tapatalk
 

Antony Kokes

Registered User
I spoke to a transmission specialist today & they said it sound like the gearbox has a problem rather than the switch.
Cost to take out rebuild & refit is a £1500 job they said
 

Antony Kokes

Registered User
Are you sure it’s not going into limp mode. Do y.ou get any beeps when you start the car


Sent from my iPhone using Tapatalk
I can try tomorrow as it is parked on my parents drive but I do think I get a long single beep.

Are you sure it’s not going into limp mode. Do you get any beeps when you start the car


Sent from my iPhone using Tapatalk
I had a previous problem when it was parked up for 6 months before and the plenum drains blocked and flooded the car.
I replaced the ccm with a like for like & it did the job the electric windows started to work again as did the doors locks.
The remote key does not work the locks so I thought it just needed re programming.
From memory I do think I get a single long beep I can check tomorrow
 

simo79

Registered User
The problem is that’ the beep can come up with lots of things.
Check the dash lcd display, if the gear number all come up with a red box around them I think that’s an electrical fault, if they come up with a red border I think it’s mechanical.

I had an intermitant fault on my rs6 (which I believe uses the same box), if your savvy with a lap top, buy diagnostic cable of eBay £10 and download a lite version from the Ross tech website (vcds). It will tell you all the fault codes in the car. Then you can find out exactly what’s up


Sent from my iPhone using Tapatalk
 
Last edited:

Antony Kokes

Registered User
The problem is that’ the beep can come up with lots of things.
Check the dash lcd display, if the gear number all come up with a red box around them I think that’s an electrical fault, if they come up with a red border I think it’s mechanical.

I had an intermitant fault on my rs6 (which I believe uses the same box), if your savvy with a lap top, buy diagnostic cable of eBay £10 and download a lite version from the Ross tech website (vcds). It will tell you all the fault codes in the car. Then you can find out exactly what’s up


Sent from my iPhone using Tapatalk
Thank you I was thinking about purchasing the cable but thought the software was a bit expensive. I do believe the local garage used the same diagnostic software. I'll check today many thanks
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
The 5HP 19FLA transmission has a coupler inside the torque converter TCC and its function is to slide gradually until it is fully locked up. In 2.7-liter twin turbocharged model from gear 3 or higher, in 2.5 liter TDI starting from the second gear and up. In the TCM has software that manages it DST ( digital shift programme) Helps to check fault codes.
 

Antony Kokes

Registered User
The 5HP 19FLA transmission has a coupler inside the torque converter TCC and its function is to slide gradually until it is fully locked up. In 2.7-liter twin turbocharged model from gear 3 or higher, in 2.5 liter TDI starting from the second gear and up. In the TCM has software that manages it DST ( digital shift programme) Helps to check fault codes.
Thank you for your reply. I am working away on Friday for 8 weeks. When I return I will purchase the cable & software as recommended by simo79 & I will update the post then thank you for everyone's time as I really like driving this car & want to get it running again
 

thawatchai2510

Registered User
Try to check red block on dash board.
Dianostic which vcds same amiram said.
And lim mode can coming up from many case electric machanic for me a6c5 tiptronic from generator the charger was swing the rang is 14 - 16 vdc ripple.
It report from vcds to see generator.
 

Attachments

  • DSCF0420.JPG
    DSCF0420.JPG
    1.4 MB · Views: 600
  • DSCF0655.JPG
    DSCF0655.JPG
    1.2 MB · Views: 569
Last edited:
Top