Audi A4 major leak

Weemaca

Registered User
Alright ppl
I have had a major coolant leak on my Audi A4 avant (2004) 190bhp
120000 miles full ASH
The same issue happened three years ago and it turned out to be the J-plug that was at fault so I thought it was the same thing but have been told by a local garage that it's my water pump
So I am having it replaced with the belts etc with a kit called GATES ?
Has anybody on here used or no of them and are there stuff any good
Thanks


Sent from my iPhone using Tapatalk
 

neil ratcliffe

coupe rebuild master
gates are a very good belt. when i did the alli pulleys on my 300zx and my gto. i used gates belts. and most of the motor factors around my way sell them. so i would recomend them.
 

Weemaca

Registered User
Thanks for the reply Neil got the car back at 8 tonite and what a difference runs much better and pulls better well seems to anyway
guy at garage has sayed he thinks the belts haven't ever been changed and that the water pump was totalled so fingers crossed that's the end of it
Thanks again for your input


Sent from my iPhone using Tapatalk
 

neil ratcliffe

coupe rebuild master
good stuff god job the belt didnt let go or that would have been very expensive. glad you are happy with your audi,
 

Weemaca

Registered User
I have the service paperwork and the belt got changed at 30k miles not the pump so the pump and other bits have been from new
Car has 120k on it now so it's been well over due to get changed


Sent from my iPhone using Tapatalk
 

Weemaca

Registered User
I think it's a bit of luck and good driving (wife is taking the credit for that lol ) as the car isn't pushed hard or abused


Sent from my iPhone using Tapatalk
 
Top