Audi A4 B8 Avant Tow Bar

Watson306

Registered User
Hi again,
One of the jobs I have planned for my Avant is to fit a tow bar.
I've got a few quotes and the cheapest quote I found kind of indicated that it wont be the genuine electrics because I shouldn't be too worried about parking sensors and other driving assist options.
And that was £400 for a Westfalia detachable bar.
With the great resources on this site I have found that my car does have the pink plug in the right hand side rear of the boot.
I did know that it had hitch prep before I found the plug but wanted to get a better indication.
So I have a few questions :
Is Westfalia the best tow bar for the A4 Avant?
Is it completely invisible when the Swan neck is removed?
How easy is it to fit myself Inc the electrics (I've fitted a Jeep Grand Cherokee one many years ago and it took me probably 4 or 5 hours). I'm happy to pay someone to fit it but I want it done correctly at the right price - if that makes sense?

Thanks in advance.
 

George Crawley

Registered User
It's very easy as long as you follow the instructions properly. Seeing as you've got the prep I'd go for the dedicated electrics which just need plugging into that plug (you'll need these coded but someone won't charge very much for that if you can't do it). I was 19 when I fitted mine, having never done one before, it's more time consuming than anything and just needed a large socket set, screwdrivers and pop rivet gun if I remember correctly.
I fitted the Westfalia from PF Jones which is what Audi fit themselves and yes, it is completely hidden when the swan neck is removed, even the electric hook-up folds up out of the way.
 

Watson306

Registered User
Hi All,
I've now fitted a westfalia tow bar and I brought the dedicated Audi loom, but I'm not feeling confident from step 12 on the attached image. I don't know what the 3 pin socket the wires need moving to is. Any ideas from anyone that's done this previously?

Thanks in advance
 

Attachments

  • IMG-20210610-WA0000.jpeg
    IMG-20210610-WA0000.jpeg
    284.1 KB · Views: 29

George Crawley

Registered User
Hi All,
I've now fitted a westfalia tow bar and I brought the dedicated Audi loom, but I'm not feeling confident from step 12 on the attached image. I don't know what the 3 pin socket the wires need moving to is. Any ideas from anyone that's done this previously?

Thanks in advance
Hi, sorry for late reply.

That seems a strange install for a dedicated system (although it has been over 3years since I did it so I may be wrong). If you have dedicated electrics already, there should be no need for depinning anything - at least with the kit I used. For me there was a red (think it was red!) plug hidden up by the BCM2 module which plugged into the loom that came with my kit. Do you not have that plug? Mine was wrapped in foam so have a good search for that.
 

Watson306

Registered User
Thanks for getting back to me.
I do have that plug but when I plugged into it I got all sorts of errors - esp, brake lights, and start/stop.
It might be just a case of coding maybe but I dont know why it says about these wires.
 

George Crawley

Registered User
Thanks for getting back to me.
I do have that plug but when I plugged into it I got all sorts of errors - esp, brake lights, and start/stop.
It might be just a case of coding maybe but I dont know why it says about these wires.
To me, those 2 wires sound like the CAN-bus wires. Because you've got the prep you shouldn't need to do that step because the can-bus connections are facilitated through that red plug - but again this is a different kit to the one I used. I would just plug it all together, forgetting about those 2 wires, and code it. Hopefully that's all it'll take. Let us know how that goes!
 
Top