1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

ASN Oil Level

stevey83 Apr 5, 2020

  1. stevey83

    stevey83 Active Member

    219
    27
    28
    Ive recently done an oil change, and sump removal and pickup check on my 3.0 v6, but now im running into a problem. This car had an oil level senosr fault when i bought it, so replaced it with a new one, which cleared the sensor fault on the DIS, but now im getting the yellow low oil message.

    My understanding is this engine holds 6.2 litres of oil, which i have put it, but cannot get the oil to show on the dipstick. I even added another 500ml but still nothing. I dont want to overfill, If i have to ill remove the sump again and check the dipstick is fully going in.

    Have i put the right amount in?
     
  2. Avatar

    snack-media
    Advertisement


  3. HelenB

    HelenB Member

    31
    9
    8
    3 different sites online say ASN is 6.3 litres so it's had 400ml more than that.
     
  4. quattrogrip

    quattrogrip Member

    56
    12
    8
    Is this petrol or diesel engine as the diesel is over 8l of oil.

    Sent from my H8416 using Tapatalk
     
  5. stevey83

    stevey83 Active Member

    219
    27
    28
    Petrol
     
  6. joinerman

    joinerman Well-Known Member

    13,389
    594
    113
    Get a longer dipstick, problem solved. LOL :cheerful:
     
  7. Mike B

    Mike B Well-Known Member

    1,354
    63
    48
    Are you sure of the amount you put in?If the dipstick is right down in the holder then it and the sensor are saying its low.Have you run the engine to see if it makes a difference?Maybe drain the oil and check how much comes out.
     
  8. blackpool1974

    blackpool1974 Member VCDS Map User

    177
    5
    18
    I also have ASN and previously had random oil low message on DIS, I also changed the sensor (£5 china job) fixed the fault. Usually came on after about 30 miles open bonnet close bonnet and would go away and then randomly come back on.

    when I had a sensor fault it didnt come up on the DIS saying sensor just low oil All the time. If you know you have the correct amount of oil then it has got to be the sensor, unless you are misreading it and it is actually saying low pressure which I have had also. This was caused by a crappy oil filter and went away as soon as I changed it.
     
  9. stevey83

    stevey83 Active Member

    219
    27
    28
    Thanks for the reply.
    i have changed the sensor with a cheap ebay one, which im sure is the fault, the original sensor was giving me a sensor fault on the DIS all the time. I used to have the oil pressrue fault but again that was a new sensor job and it went away.
     
  10. blackpool1974

    blackpool1974 Member VCDS Map User

    177
    5
    18
    Does VCDS say anything as I dont think mine did as it thought it was genuinely short of oil

    Worth a punt on another cheap sensor, mine has been ok for 2 1/2 years now
     
  11. stevey83

    stevey83 Active Member

    219
    27
    28
    Nothing to read in VCDS really, you can check oil level under instruments but the reading means nothing to me! I think another sensor would cure it.
     

Share This Page

Do Not Sell My Personal Information