Another convertible roof issue - 02000 implausible switch position

awaters

New Member
Newbie, so please be gentle.
Initially the roof stopped working at the stage where it would unlock at the front but would not raise the roof.
VAGCOM showing codes 01618 - Top Valve 2 (N272) and 01984 - Top Valve 2 (N341).
Looked through the forum and found a number of posts regarding cleaning the commutator and opening the brushes which I have tried but to no avail.
The solenoids were pretty crusty so it looks like moisture has been getting in (High level brake light I suspect) and I seemed to be getting fluctuating resistance measurements across the solenoid terminals.
After cleaning all the contacts I then swapped solenoids 2 and 3 over, cleared the codes, and sure enough the error code went to 01985 - Top Valve 2 (N342).
I have replaced 2 of the solenoids and now the roof goes up and gets to the stage where the front goes up, the rear folds forward and the compartment lid rises. Unfortunately that's where it ends. The lid then comes slowly back down and the code 02000 - implausible switch position appears.
If I press the roof switch again the lid will rise again but nothing more and will slowly drop. Closing the roof from this position still works.
I have tried clearing the codes and manually opening and closing the roof several times but I can't get it to go past the lid opening stage.
Anybody have any ideas. I have attached the log file showing the block measurements up to the point where it fails if it helps.
 

Attachments

  • LOG-26-001-xxx-xxx.txt
    5.7 KB · Views: 12

awaters

New Member
When I run output tests from vcds, inparticularly the two relays, I get different tones from the motor running. I'm assuming that this is the motor running clockwise and anti clockwise. Does anyone know if this is correct and is normal. Cheers, Andy
 

Cabbyfan

Registered User
02000 is the 2 latches just behind the seatbelts. There is a microswitch inside the lock. On mine was switch was open and the other closed. They both need to match.
 

awaters

New Member
02000 is the 2 latches just behind the seatbelts. There is a microswitch inside the lock. On mine was switch was open and the other closed. They both need to match.
Thanks for the reply Cabbyfan.

So that's the microswitches F199 and F200 ?
I can see a value for F200 in the measuring block values on vcds but can't find any reference to F199.
Any idea how to check the two values together.

Andy
 

awaters

New Member
Went through the measuring blocks again and it would appear that the microswitch on the drivers side (UK) is F200 and responds to the rear latches being opened and closed whilst the microswitch on the left is F290 and responds to the lid opening and closing. Anyway I removed the latches and had a fiddle with the microswitches and wiring and put it back together and life is good again.

Probably not a permanent fix but thanks for pointing me in the right direction. If it happens again I know I'll have to change one of them.

Thanks again,

Andy
 

Cabbyfan

Registered User
Glad it's fixed. The switch on the driver's side seems to get more sticky than the other one.
 
Top