1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Annoying revs

Alex Holmes Aug 4, 2018

  1. Alex Holmes

    Alex Holmes Member

    76
    39
    18
    Evening all,

    My 2.0 tfsi avant seems to suffer from hanging revs between gear changes. Its properly annoying especially coming from a car that didn't do it. So after a little research and brain picking, apparently it's a feature used for smoother driving and to aid gear changes. For normal steady driving ive got used to changing gear really slowly but it kind of ruins the buzz when I'm giving it some abuse as it sounds and feel like I've forgot to take my foot off the throttle! I have reset the throttle position as advised but im not sure if it's made a difference or wether its physcolgical! So does anyone else suffer with this? Can you have it mapped out? I fancy a stage 1 remap for a little extra grunt so could have it done then.

    Cheers chaps!
     
  2. Avatar

    Google AdSense Advertisement


  3. Metalsmurf

    Metalsmurf Member Team Dolphin Grey TFSI Owners Group Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    56
    21
    8
    It sounds like you have a vaccum leak somewhere, mine did this for a while, and it turned out my oil dipstick wasn't seated in properly.

    Sent from my SM-G955F using Tapatalk
     
  4. Alex Holmes

    Alex Holmes Member

    76
    39
    18
    Thanks for the reply, do the revs on yours die as soon as the clutch is pressed? I have watched a few vids on YouTube and their standard cars (like mine) dont seem to hang revs. Ill check my dipstick but i think that is fine, its just really annoying!
     
  5. Alex Holmes

    Alex Holmes Member

    76
    39
    18
    Ive just found this vid on YouTube of the exact issue only on an s4 instead. Mine seems to do it throughout the rev range not just at low Rpm.
     
  6. Metalsmurf

    Metalsmurf Member Team Dolphin Grey TFSI Owners Group Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    56
    21
    8
    I would be at the lights in neutral and the revs would pick up to about 1100 rpm like I was trying to race the car next to me, if I blipped the throttle it would go down then creep up. I checked the engine bay and I hadn't pushed the dipstick down. I got a cel a short time later and I replaced the DV and the PCV and it's been fine ever since, not sure if the 2 issues were related.

    Sent from my SM-G955F using Tapatalk
     
  7. Metalsmurf

    Metalsmurf Member Team Dolphin Grey TFSI Owners Group Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    56
    21
    8
    Yeah mine was similar.

    Sent from my SM-G955F using Tapatalk
     
  8. Alex Holmes

    Alex Holmes Member

    76
    39
    18
    Not sure if mine does it at idle or not, i know the DV was replaced just before i bought the car not sure about the PCV. That could be the culprit!
     
  9. i3oricua

    i3oricua Active Member Team Brill Red Audi A4 Saloon

    209
    75
    28
    Does your cruise control work? I'm making an assumption that you have one. Look up clutch pedal switch and see if the symptoms sound familiar. Very cheap part and very easy to change. I think that may solve your problem.
     
    Alex Holmes likes this.
  10. Alex Holmes

    Alex Holmes Member

    76
    39
    18
    I retrofitted cruise, but yes it works a treat. I have read up loads about clutch switches being the cause and it affecting cruise. As it still works i just opted for the throttle position reset. I'm thinking it possibly does it as part of emmisions? Maybe may car could be 1 of a batch that had this feature for a certain year or production period? The pre and post models may not have had it. It's a theory at least!
     
  11. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,127
    3,659
    113
    mine does it and allways has done since i purchased it 4 years ago with 29k miles.....and there is nothing wrong with my old bus, its a bit irrating sometimes but I have pretty well sussed out how to shift quickly and at the same time keeping rpm's manageable …..if there is a fault on my old bus then It would have shown its head by now.
     
    Alex Holmes likes this.
  12. Avatar

    Google AdSense Advertisement


  13. boffin486

    boffin486 Well-Known Member

    137
    269
    63
    Yes indeed folks, my car does the rev hanging too - but NOT every time! Seems to be an intermittent event on mine - I already fitted new DV & PCV valves as well as a clutch & brake switch (to get the cruise control working - which it does now, perfectly). It seems odd that it doesn't happen every time I change gear, only sometimes. Personally, if this is a 'designed' feature, I feel the designer in question needs a kick in the slats.
    But it can be lived with I suppose........ :shrug:
     
    Alex Holmes likes this.
  14. Alex Holmes

    Alex Holmes Member

    76
    39
    18
    I have got used to changing gear a lot slower and ill be honest it does make for smoother changes, its just a shame the feature doesnt cit out above a certain rpm when your clearly "giving it some bast*rd!" It doesnt do it as much when you short shift into 5th and 6th when hypermiling. It's worst between 1st and 2nd.
     

Share This Page