1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Android RNS-E

docurley Jul 3, 2015

  1. lincoln_dj

    lincoln_dj Active Member VCDS Map User

    483
    65
    28
    I've found viper hasn't done anything - i may not have it configured right though.
    Poweramp sounds better than native music app. but poweramp is no good for listening to DAB/FM, spotify, movies, etc.

    Ah yeah, my ELM327 dongle works well with Torque Pro too. Can connect to both ELM327 and my phone via bluetooth at the same time which is handy.
    Not tried a line converter yet - haven't decided which one is best - since my HU already came with a bose loom so m 4 x speaker outputs are already phono - so think i'll need the PAC SNI35.

    Camera is this:- http://www.ebay.co.uk/itm/USB-2-0-F...-DVR-Camera-720P-HD-for-Android-/231807723281
    The picture quality is good enough, but it seems to struggle when the sky is bright, it makes everything else look dark. will probably upgrade in the future but does me for now. The head unit picked it up with no setup needed, and as long as it was recording when you turn the car off it will automatically start recording again next time.
     
    HHS3 and leshkin like this.
  2. Avatar

    snack-media
    Advertisement


  3. dieleco

    dieleco Registered User

    22
    4
    3
    My DVR Camera works the same way as you describe, also automatically delete the oldest files when the USB stick /SD card is full, so I don’t have to worry about deleting the video files by myself.

    The mine is: http://xtrons.co.uk/dvr015-xtrons-android-units-dvr-camera.html
     
  4. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    Yes, there is a process you need to go through to make it work:

    Install > Open the app and install the driver via it's settings > reboot > Open the app and enable the EQ for the speaker, then play about with settings until you find what works for you.

    It's not the most intuitive app, but once working you just forget it's there. Do remember that it will work in conjunction with other EQ settings in other apps like PowerAmp, or the main EQ of the head unit, so play about with the settings until you find what works for you.
     
    HHS3 likes this.
  5. HHS3

    HHS3 Phantom Black S3 - R-Tech Stage 2+

    1,120
    531
    113
    Perfect thanks fella's, really appreciate your help.

    Last two questions (I hope!), I'm only going to be using the HU for listening to music through my phone via bluetooth (with Poweramp & Viper installed), satnav and reverse camera.
    • Do I have to bother with the whole Malaysk ROM part to use the above features?
    • Is a 3G dongle and pay plan required in order for the satnav to work?
     
  6. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    No problem! I hope you then share the knowledge too :)

    To get Viper to work, yes, you will need root to install its driver.

    I don't use a dongle and instead use my mobile tethering allowance. If you do not plan on streaming music or using anything online related, then no dongle is needed. Just a decent WiFi signal to download the apps you need at home. You would have to get a decent offline nav app like Sygic or a very cheap osmAnd http://osmand.net/ and then sync the maps for offline use.

    I would say that being able to monitor traffic/accidents via Waze or Google Maps and stream music is a huge bonus of these units
     
    HHS3 likes this.
  7. HHS3

    HHS3 Phantom Black S3 - R-Tech Stage 2+

    1,120
    531
    113
    Yes definitely! Had my S3 for nearly a year now but only recently started posting on here, must say this forum is a lot more friendly than previous sites I've been on, probably due to the type of car we own no doubt haha!

    Ah yes mobile tethering, great idea! Just got to check to see what my plan allows, the traffic function you mentioned would be handy so this would definitely come into use. I like all sorts of music but I am mainly a dnb head so have all the music I want on my phone and the odd CD pack. I'd mainly drive around with the map up, as I loved the feature when I drove my brothers old GT86 around back roads I didn't know, so you can roughly gauge the corner's sharpness coming up :wink:
     
  8. dieleco

    dieleco Registered User

    22
    4
    3
    Lincoln, have you been able to see the oil temperature of your car in Torque Pro APP ?
     
  9. lincoln_dj

    lincoln_dj Active Member VCDS Map User

    483
    65
    28
    do you recommend Waze pretty highly? Have heard good things about it. Was going to just use TomTom Go Mobile, and happy to pay the £15 a year for it, and includes speed cameras and traffic info. But if Waze works just as well and works out cheaper....


    and dieleco - oil temp not working in Torque, but it also isn't working in my DIS at the minute either! Think my oil sensor must be disconnected or broke as I'm sure it used to work in my DIS!
    Torque should be able to pick up any value VCDS can see in the engine module. I've set mine to show boost, oil/coolant/intake temp and couple other bits.
     
  10. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    Sure, it's tough to beat free :) It uses Google's traffic updates, decent maps that update very quickly and camera alerts are very good too. Out of the bad points, it will not work in offline mode (was next to useless on a recent trip to Scotland, where phone reception was non-existent ) and I'm not a huge fan of the whole social bullpoop that they insist on, but on balance it's a solid nav app that works well and is free.

    In all honesty though, I only used it because of speed camera database as Google Maps does not have it built-in. I recently bought http://www.sygic.com/speed-cameras/features and this thing provides an overlay for cameras in Google Maps, which is pretty nice as I like Google Maps :)

    For a cheap way to do offline navigation, osmAnd+ is very good and recent updates made it better. At a couple of quid, it's great value for money too.
     
  11. dieleco

    dieleco Registered User

    22
    4
    3
    Thanks lincoln_dj, you're very helpful.

    Anybody who has installed the rear camera in an Audi A3 (3 doors), how complicated is it?, Any manual, webpage?.

    Thanks.
     
  12. Avatar

    snack-media
    Advertisement


  13. dieleco

    dieleco Registered User

    22
    4
    3
  14. HHS3

    HHS3 Phantom Black S3 - R-Tech Stage 2+

    1,120
    531
    113
    Thanks again leshkin, very useful information as always! I'm just doing some research on them all now to see what I'll go for.

    I'm also interested in how/where people have fitted their reverse camera, any guides/explanations would be most appreciated. I just had a quick search on here and on Google but couldn't find anything useful.
     
  15. lincoln_dj

    lincoln_dj Active Member VCDS Map User

    483
    65
    28
    hmmm. i'd been getting confused regarding the lack of sound from sub/rears as all the info online shows non-bose systems with the issue, and the adapters are for non-bose. plus my stereo seller said just plug & play with bose. well......

    turns out i dont have bose! i've got bose on the speaker covers for some reason. but i have the 8P3035382 blaupunkt sub unit, not the 8P3035382C bose (according to VCDS). so means i'll need one of these phono adapters. however, the harness i'm using is already using phono connections for all 4 speakers so gunna need something different i reckon!

    think the Viper4Android EQ/amp software ive installed has worked though, the fronts sound good even when using spotify. I've even reset the PowerAmp EQ back to flat :)
     
    leshkin likes this.
  16. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    Sorry its been a while but I now have the DAB+ working with good signal now and also upgraded the firmware which was an easy job I have to say and sorted our some issues like track changing while in another app while using poweramp for music playing (great App i have to say).

    New firmware give the unit a fresh look as well.
     
  17. DrEvil

    DrEvil Registered User

    315
    23
    18
    Wow, can't believe I've missed this thread. I too have an android unit - very much enjoying it. Mapped a few buttons around to make things better. I also got a dual core and wish I had got a quad core to half the boot up time. Oh well. Main thing I want to sort is mapping the speak button to google voice and to get voice dialling going properly via the HU rather than the google voice on the phone.

    What's also handy is to use Tasker so when the HU connects to your phone's bluetooth, my phone wifi hotspot auto activates and it disables the screen lock too. This all switches back to normal when bluetooth disconnects from your phone.

    Sound is something that isn't quite right for me. At low speeds its not too bad, but higher speeds and therefore volumes it loses the base. I'll try Viper to see if that improves things, at least on the non-radio side of things. I also only have an amped rear setup (non-Bose) so maybe I should add a sub?

    The DAB+ is interesting docurley - last I knew you had received your adapter but it was crushed. Did you just use the Noolec adapter and the aerial splitter? I was considering adding a separate external aerial or trying to use the built in aerial on my driver side rear window that isn't used, but if that gives good reception then that is an easier and cheaper solution. Which app are you using?
     
  18. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    Yeah
    Yeah I got sent a new unit and then I bought a splitter and exstention adapter leads to link it all up and it works a treat.

    Sound quality on the Radio is not great and from what I have read its something to do with the hardware which can be resolved.

    Our side the radio I run poweramp and that just brings the whole unit alive and with the new firmware I can now change tracks while using Waze navigation (I also run a data dongle).

    Do you and Hi/Lo converters for the rear speakers?
     
  19. audi5inline

    audi5inline Registered User

    63
    5
    8
    Ok, so i have the none bose system, what extras do i need to install to make this unit work properly ? I will mainly use the unit for spotify.
     
  20. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    |For none bose the rear speakers work the same as a bose so they need a low output to work correctly. Now on some of these units they have a low out put which you link in to the units normal outputs but if like mine there was a **** load of white noise you will have to run a hi/low adapter to control the sound output for the rear channel.

    Just to point out I had to also do a similar thing on my old B5 A4 none bose when I pulled out the old unit to run a pioneer setup due to the rear speaker system being amped.

    if you look back over the thread im sure i listed the parts needed which taps in to the speaker loom.
     
  21. audi5inline

    audi5inline Registered User

    63
    5
    8
    Thanks for your help, but im still not entirely sure on how to connect it all...
     

    Attached Files:

  22. DrEvil

    DrEvil Registered User

    315
    23
    18
    Hey docurley

    Yep, I've done the hi/lo for my rear. For anyone else looking to connect those on this setup - I've tried to explain it here: http://www.audi-sport.net/xf/threads/help-with-wiring-and-rear-volume.258989/#post-2671772

    If I had to describe the sound its like it's all coming out of the tweeters when at higher speeds, especially as you turn the sound up when means you hear the tweeters even more. It might be that playing with Viper could help this. Not sure if what i need is a cheap second hand sub (I'm sure I would be told that the real best solution, but not worth the money for me is to get a proper amp, new speakers and sub and sound proofing).

    So as I understand it the thing with radio is that it feeds sound direct rather than go through the HU EQ. But if you have DAB on a USB adapter it actually should go through the HU so that could be a good work around.

    Two questions
    - are you using the Wavesink DAB app, or have you found something else?
    - Can you put playing CDs, USB music and Bluetooth music through poweramp?
     
    Last edited: Mar 4, 2016
  23. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    Using Viper app will help with sound EQ settings and will make things sound quite a bit better for any source of sound that comes from within the Android OS. It's definitely worth the free price tag :)
     
  24. audi5inline

    audi5inline Registered User

    63
    5
    8
    So do i understand correctly that there are rear speaker wires in the HU main loom that need to be cut and connected to the hi/lo adapter ? Trying to understand it all before installing it, also tryung to source all the parts so i can install all at once
     
  25. DrEvil

    DrEvil Registered User

    315
    23
    18
    That's right, you take the Rear Speaker direct output from the HU (the wires are in the HU main loom that you have) cut those and connect to the hilo (i used crimps for good connection that shouldn't risk jiggling loose and then wrapped them in tape for extra insulation from interference if that actually helps).
     
  26. audi5inline

    audi5inline Registered User

    63
    5
    8
    Ok clear, and how do i connect the sub ?
     
  27. audi5inline

    audi5inline Registered User

    63
    5
    8
    This picture i found made it clearer, but will i need 2 Hi/Lo adapters on a non bose system ?

    [​IMG]
     
  28. DrEvil

    DrEvil Registered User

    315
    23
    18
    Wondering if I could get some help on this.

    So when I loaded this, it automatically came with a pop up to install a driver. I selected super high quality and it didn't like think (think I needed something else to be installed) so I installed the high quality one. If I got to settings it gives me the option to uninstall driver (so I didn't click on this)- so I assume as it gives me the option to uninstall a driver that I do have the driver installed?

    Rebooted and then opened it up with a CD playing. Went to bass boost on the equaliser with Viper4Android (was in phone speakers mode which I assume is the HU output!) - but it made no impact. Tried other options and manual and it made no difference to the sound - so a bit confused as to what I should be doing.Could someone remember what they did to get this working?
     
    Last edited: Mar 4, 2016
  29. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    Sound like you uninstalled the driver and now you have a dumb unit, I would say do a factory reboot on this headunit and reinstall the .
     
  30. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    Bose requires two Hi/lo adapters none bose only needs one not unless your front speakers are amped
     
    HHS3 likes this.
  31. DrEvil

    DrEvil Registered User

    315
    23
    18
    I didn't click on the uninstall (edited my post to be clearer).
     
  32. audi5inline

    audi5inline Registered User

    63
    5
    8
    Thanks, all clear for me now :yahoo:
     
  33. Avatar

    snack-media
    Advertisement


  34. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    Upgrade the firmware this should helpand its easy to do just pop over to XDA.com for ROM's, and there is meant to be a hardware fix for the radio

    Download poweramp (it a music player) and see if that works better its got a powerful EQ built in to it and should help sort the sound out
     
  35. docurley

    docurley Moderator Staff Member Moderator

    4,084
    94
    48
    some apps to have

    To find out headunit spec
    https://play.google.com/store/apps/details?id=com.finalwire.aida64

    Great music player with great EQ built in (transforms the sound)
    https://play.google.com/store/apps/details?id=com.maxmpz.audioplayer

    ECU scan tool and way more (need ODB2 bluetooth dongle)
    https://play.google.com/store/apps/details?id=org.prowl.torque

    One of the best SATNAV for android out there (needs data)
    https://play.google.com/store/apps/details?id=com.waze

    If you want DAB then you will need this software (you will need a few thing (harware) for this to work) best currently out there I can find
    https://play.google.com/store/apps/details?id=de.ses.wavesink

    Firmware and other info
    http://forum.xda-developers.com/android-auto/mtcb-software-development

    It would be interesting to see what Apps people are running
     
    Last edited: Mar 4, 2016
    HHS3 likes this.
  36. tony mc

    tony mc Registered User

    1,124
    644
    113
    hi all, i have a little to add, to this thread about full bose set ups,

    i have this unit and full bose set up in the car, i had dreadful alternator whine and a major buzzing noise when the head lights were on, so, after seeking lots of advice on here and other places, i found out i needed ground loop isolators instead of hi lo converters. wired in the same way from the head units speaker outs to the bose signal wires in the car.

    now then, this stopped 90% off the interference, but the buzz was still there from the headlights, so i put my hand in my pocket again and bought one of these little fella's..... http://www.ebay.co.uk/itm/RCA-Noise...253937?hash=item3abeaf2ab1:g:4R4AAOxyaURTfKM8

    i wired some rca plugs to the cars speaker signal to amp wires and put the blue wire to the white amp wire on the audi loom and it all works spot on, no alternator whine and buzz from the headlights,

    thought i share as i found there wasnt a lot of info for people with full bose.

    cheers.
     
    HHS3 likes this.
  37. hooblah

    hooblah Registered User

    47
    5
    8
    Hey guys what headunits are you using?
    Im considering getting a Dynavin N6, how does this compare?
     
  38. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    The Android units are a good couple of hundred pounds cheaper normally, have more options as far as apps go (full access to Google App store) and there are a couple of different designs to chose from as well as endless user interface customisation.

    Dynavin units are better put together, better sound out of the box apparently and seem to just work out of the box.

    Both can do DAB (some Android units don't), should all come with all of the adapters you'd need. Both will do BT audio streaming/handsfree, DVD, USB mp3s etc...

    I'd say that if you are normally happy with what you get on a given unit, don't want to mess about with install too much and just want it to work, Dynavin is a good choice. If you want to customise the hell out of how your unit looks, which app you use for navigation, etc and want things like Spotify, Google Music, online radio streaming (instead of DAB?) directly on the unit via a phone tethering plan or a dedicated 3G adapter, then Android is the way to go. You can even stream Youtube, Plex or Netflix in your car! I'm never bored when I have to sit in the car and wait around for some reason :)

    I favour the Android option as it gives me the ability to customise it heavily, native access to apps I may be using on the phone already for anv and media, and it integrates with online stuff very well. Can also act as a dashcam recorder too!
     
  39. lincoln_dj

    lincoln_dj Active Member VCDS Map User

    483
    65
    28
    for the rear speakers on my non-bose S3 I used an xtrons hi/lo adapter and ended up putting my own pin ends on the 4 wires from the hi/lo unit, this allows you to connct them to the OEM side of the quadlock adapter

    part number is N-906-844-05 and my local TPS had them in. need a soldering iron to do them properly but it was easy enough.

    I've got my hi/lo set to pretty much their highest settings. sounds much better than before now but still not quite as good as the RNS-E did. I was running viper amp to boost the sound, but it didnt work when using the stereo's default mp3 player app. But since sorting this hi/lo adapter i've disabled viper and got it sounded ok through the stereo's own EQ.

    got an issue with my USB ports not working now!!

    also, my stereo is an absolute pain to remove and put back in. currently got it half an inch out but wont come any further, it's stuck at the bottom. So my recommendation is get EVERYTHING (aux inputs, USB cables, cameras etc) working before fixing the stereo in place.
     
  40. lincoln_dj

    lincoln_dj Active Member VCDS Map User

    483
    65
    28
    or buy them pins for 50p-ish each and no cutting needed :)
     
  41. leshkin

    leshkin Hold my beer... VCDS Map User

    3,032
    1,887
    113
    Sounds like the exact issue I have with my unit on a S3 also. I figured that you can remove the trim piece just below the unit (the one around the hazard and other buttons). It's held in with a few clips that are very easy to pop out if using one of those soft plastic trim removal wedge tools. With this piece out, you can then reach the bottom locking pins for the unit and disengage them without the stereo keys. I got it to a point, where it's quite painless now.
     
  42. DrEvil

    DrEvil Registered User

    315
    23
    18
    That sounds like a good and better idea, would have been cleaner! Wasn't a huge issue to do crimps. Also crimped in the power to the antenna so it didn't keep coming loose.
     
  43. DrEvil

    DrEvil Registered User

    315
    23
    18
    So can anybody here tell me what settings they are using for Viper4Andriod?

    Cheers!
     

Share This Page

Do Not Sell My Personal Information