Air suspension levelling problem

mattyb6

Registered User
Hi
Our lasses dad has a 2.7tt all road, on an 02 plate

As of this morning is wont self level on the front passenger.

I can here the compressor kicking in and the rear lifts up.

I think I can hear a hissing from the NSF wheel arch,

What are the chances the bag is shot or it's just a hose, or even a sensor.
I'm not exactly sure if there is a hissing for sure, but il check soon as I get a chance

Anything I should look out for?
 

Arrkon

Back in a "B"
Staff member
Moderator
Regional Rep
could be hose seal, could be bag (most likely). best option is to spray soapy water all around the area and look for bubbles.
 

mattyb6

Registered User
could be hose seal, could be bag (most likely). best option is to spray soapy water all around the area and look for bubbles.
Just got around to ready this
Cheers

Yeah me and another member where looking into this on a different allroad

Looks to be quite common.
Il have a good look, and put some soapy water on.
I haven't had a chance to speak to the owner about it
 

Paul @ Unit 9 Remaps

Registered User
Bag solved our issues £130 for a new one from germany with 2 year wareenty ' cant go wrong
 

mattyb6

Registered User
Nice one Paul
Not too bad of a price either marra
 

mattyb6

Registered User

Arrkon

Back in a "B"
Staff member
Moderator
Regional Rep
eBay user ID: aerosus_de

Just got a new one from them, fitted the other week. No problems thus far, and got it on next day shipping for £20.
 

Arrkon

Back in a "B"
Staff member
Moderator
Regional Rep
nope dont have to, would suggest if you can afford it you do the pair, as if one is failing the other wont be far behind...
 

Morne

Registered User
nope dont have to, would suggest if you can afford it you do the pair, as if one is failing the other wont be far behind...

Hi got my new bag thanks for that one question is it difficult to fit as i took the wheel of and wasn't sure how to do it and on mine the pipe that goes into it has been bodged glued it so i would need to gut it off then got to try and extend it,so how does the air pipe fit onto it oi know the new one has the little nipple thing but like i said on myne cant c what is on the pipi bit as covered with the bodged job
 

Arrkon

Back in a "B"
Staff member
Moderator
Regional Rep
The new one should already have the brass nut attached, cut the pipe off as close to the old nut as possible and it's a push fit to the new. To remove the strut, release the top arms from the dreaded pinch bolt, undo the three bolts in the engine bay above and remove like a normal shock absorber. Just remember to grease the o-rings top and bottom of the new bag.
 

Morne

Registered User
Ok without sounding dumb but i looked in the engine bay and i saw one bolt so not sure im looking n the correct place
 

Morne

Registered User
Ok the problem i have is the rad pipe it is glued bodge previuos guy
allroad.jpg
in so if i cut it off not sure it will reach
 

Arrkon

Back in a "B"
Staff member
Moderator
Regional Rep
if you can, undo it. then remove the collar and nut from the line :)
 

Morne

Registered User
I just dont want to start it then i cant fix it then car is off the road must admit a bit scared just because of that pipe
 

mattyb6

Registered User
Where's the best place to start looking for faults with the air suspension?

No faults on vcds etc a g65 sensor.
The front is intermittent and raises sometimes, majority of the time it's on the floor.

I can't hear any hissing, the compressor kicks in and shuts off fine.

So any ideas or advice?
I don't want to be stripping everything out tbh
 

Morne

Registered User
Ok so i replaced a front bag on left side but when the car stands for a few hr the hole left side is down more then the right side what have i missed or what is wrong
 

mattyb6

Registered User
Maybe the other bag has gone aswell ??
 

mattyb6

Registered User
Or as Paul said level sensor
 

All-rod

Member
Bronze Supporter
Have you scanned with VCDS, as other readers might not pick up all faults. It is weird that both front and rear are down on one side?
Possible more leaks, but looks like there is something else here.
There is a good thread on these issues over at VwAudi forum, might get more clues over there.
Other thing i would suggest to do to try and rule things out is if you can still get car level leave it overnight with battery disconnected, this should rule out electronic faults.
 

mattyb6

Registered User
I just thought I'd update this

Finally got it sorted
The other week I got a bag piping Andy compressor kit which seemed to help

Then I ordered a new NSF air bag and straight away it was sorted

Tempted to buy it lol
 

mattyb6

Registered User
Top