1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

ABS controller

vr6gordy May 30, 2015

  1. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Can anyone tell me what signs to look for if I've got a bad abs module ... On the turn of the key I'm getting 3 beeps then a big hand break sign on the display also abs and traction lights are on
     
  2. Avatar

    snack-media
    Advertisement


  3. Paul @ Unit 9 Remaps

    Paul @ Unit 9 Remaps Registered User

    2,015
    133
    63
    Another symptom from experience is it showing a wheel speed sensor
     
  4. pauldazzle

    pauldazzle Registered User

    1,346
    122
    63
    Scan with VCDS needed.
     
  5. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Vcds won't let me log in to code abs ..if abs module was knackered would this be what it would do
     
  6. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    There no error code for speed sensor
     
  7. Paul @ Unit 9 Remaps

    Paul @ Unit 9 Remaps Registered User

    2,015
    133
    63
    Sounds like it could be a dead unit, and if it's for a 3.0 v6 petrol I binned 2 last week ffs
     
  8. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    It's for a 1.8t Why would it show after I changed the steering wheel and not before ??
     
  9. Paul @ Unit 9 Remaps

    Paul @ Unit 9 Remaps Registered User

    2,015
    133
    63
    ^ confused now. maybe linked to steering angel sensor
     
  10. sabaxter

    sabaxter Registered User

    464
    28
    28
    Have you had your steering wheel off?
     
  11. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    I can't do steering angle until I code abs
     
  12. Avatar

    snack-media
    Advertisement


  13. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Well if I've fitted new steering wheel
     
  14. sabaxter

    sabaxter Registered User

    464
    28
    28
    No need to be sarcastic a yes or no would be sufficient ive had this issue and resolved it.

    I will say no more.
     
  15. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    sorry I was sarcastic but I have already said I've changed the wheel .. How did you sort it out
     
    Last edited: May 31, 2015
  16. sabaxter

    sabaxter Registered User

    464
    28
    28
    To follow on from our pm..... Do a scan of your car if its g85 steering sensor related (sounds like it to me) do tje following

    The sensor now needs to be calibrated using a VAG-COM. Ross-Tech has the following instructions on their site:

    There are certain test conditions that must be met before doing this procedure:
    Start the vehicle.
    Turn the steeringwheel one turn to the right and one turn to the left.
    Drive in a short distance straight line on a level surface at a speed not higher than 20 km/h.
    If the steeringwheel is straight during the test drive then stop the vehicle with the wheels pointed straight
    Ensure that the steeringwheel is not moved again.

    Keep the engine running and do not switch off the ignition.

    Procedure for performing the zero position calibration for the SteeringAngle Sensor (G85) on VW Golf, GTI, Jetta, and Audi TT:

    [Select]
    [03 - ABS Brakes]
    [Login - 11]
    Enter 40168
    [Do It!]
    [Basic Settings - 04]
    Group 060
    [Go!]

    This will store the zero (centered) position of the steeringwheel. There should be a displayed message that reads: "Steer. angle sender compens OK". If you get an error, it may mean the Login was not successfully performed.

    Click the [Done, Go Back] button and you're all set.


    I did this and still had the warning so i did the test drive again and mine went off. Hope this helps
     
  17. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    I can't log in to the abs every time I try it dose nothing or kicks me ou
     
  18. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Got another abs module to try today hope this sorts it
     
  19. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Tried another abs controller today and still the same .. The only thing I can think of now is the steering control module it's the only thing what I've unplugged also I might have bought a dud unit
     
  20. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Well I've think I've found out why I can't code the abs ive been sold the wrong slip ring .. When I looked this morning at it there's no part number no sticker on been stung on eBay me thinks ... so gonna try a new slip ring and see that sorts it which I'm sure it will
     
  21. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Got the correct slip ring fitted today and same problem Scanned car and getting code 01316 check abs controller module wires and connectors .. If the abs module was knackered would it show this code .. When I tryied the new abs controller I only plugged it in I didn't bolt it to the abs
     
  22. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Checked the fuse today and it's not that need help ... Please someone help its doing my head in now
     
  23. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Just checked fuses tonight and found fuse 10 blown ...could it be this from stoping me logging in to abs ?? Can't try it now bat flat on laptop
     
  24. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Fuse wasn't blown plus it's all for heads lights .. Got break switch swoped over and still no joy so Paul you might be right with a speed sensor but there's no error code for speed sensor but with what I've read they don't always show up
     
  25. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Think I've finally found the problem it's the battery
     
  26. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Well fitted new battery and still no joy still can't code abs .. If I had a bad wheel speed sensor might it not show a code if it's fault and still be at fault
     
  27. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    This is doing my head in now anyone know what's wrong I can pay cash if someone will come to my house to help me fix it
     
  28. Ovid

    Ovid Registered User

    291
    35
    28
    Gordy have you driven the car and then checked, mine did same so i drove it and really hit brakes a few times came home cleared faults and it never through fault again .
     
  29. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Only driven it round the block ... Maybe not far enough
     
  30. Ovid

    Ovid Registered User

    291
    35
    28
    No mate i drove over 7 miles in total also you haven,t switched ESP button accidentally have you ?
     
  31. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Haven't touch the esp button no .. Wondering if the abs module is knackered .. I've got another one to try tomorrow after I go for a drive
     
  32. vr6gordy

    vr6gordy Registered User

    2,822
    193
    63
    Think Ovid has fixed it for me it's a wire into the steering module
     

Share This Page

Do Not Sell My Personal Information