ABS control Units

meatychi

Registered User
My motor has just had it's MOT and I have been told that my ABS control unit needs replacing.

According to my garage they say that it is a common fault with the A6 2.5tdi's

Is this true, it seems that all faults are common faults?

Can anyone tell me how much you would expect to pay for replacing said control unit?
 

Flying Spanner

Registered User
I would need part number, but for and ABS Unit with electronic control unit 4D0 614 111 J on a 98 A6 is £1259.2

A repair set would be £465.49 for 8E0 998 375 C which is just the ECU

THESE ARE GUIDES ONLY YOU NEED THE PART NUMBERS FROM YOUR CAR FOR CORRECT PRICE
 

meatychi

Registered User
Thanks however I will be sending it to BBA remen and getting it re-engineered 8E0 614 111A for £100 +shipping
 

meatychi

Registered User
Well I got my ECU back, fitted it and hey presto no ABS light and no fault codes!

All for £145

Loads better than the £700 I was quoted!
 

enda1

Registered User
I've got a 99 A6 1.8t. Over the last couple of weeks the ABS light and the big red brake warning light on the DIS have been coming on intermittently but are staying on for londer and longer.
I ran a vagcom scan and this is what I got

Address 03: ABS Brakes Labels: 8E0-614-111-EDS.LBL
Part No: 8E0 614 111 B
Component: ABS/EDS 5.3 FRONT D10
1 Fault Found:
01203 - Electrical Connection between ABS and Instrument Cluster
03-10 - No Signal - Intermittent

I checked the output from the wheel sensors and they are all measuring the same speed so I'm assuming they are fine.
I ran the output test on the ABS system and everything aperaed fine in that the ABS pump cycled and I could feel the pedal pulsing as each wheel valve was tested.

On Ross-Tech Wiki I got the following
01203 - Electrical Connection between ABS and Instrument Cluster: No Signal

Possible Symptoms
ABS Malfunctions
Possible Causes
Wiring between ABS and Instrument Cluster defective
ABS incorrectly coded
Instrument Cluster defective (rare)

Possible Solutions
Check Wiring between ABS and Instrument Cluster for Short to Plus
Check ABS Coding
Check Instrument Cluster

Can anyone point me in the direction of:
1) where the defective wiring (if that) could be
2) Is there a way to test my instrument cluster to see if this is the problem
3) Is there a way to test the ABS ECU befroe spending money on getting it fixed.
 

meatychi

Registered User
Not sure if you read the other post but here are the fault codes that I cleared after repairing the ECU:

Address 03: ABS Brakes

Controller: 8E0 614 111 A

Component: ABS/EDS 5.3 QUATTRO D00

Coding: 0273004284

Shop #: BB 24334

3 Faults Found:

01203 - Electrical Connection between ABS and Instrument Cluster

03-10 - No Signal - Intermittent

01203 - Electrical Connection between ABS and Instrument Cluster

31-10 - Open or Short to Ground - Intermittent

00526 - Brake Light Switch-F

36-10 - Open Circuit - Intermittent

Your results look familiar!
 

enda1

Registered User
Thanks for the reply
I Read the other post. Just wondering if the code below was what you got befroe you got it repaired.
01203 - Electrical Connection between ABS and Instrument Cluster
 

meatychi

Registered User
Before the ECU was re-engineered it wasn't possible to scan the ABS controller using both a the Bosch and theVAG-Com tools.

The codes I listed above are the fault codes that were there before the repair took place.

I have driven the car for a week now and after rescanning, there is no evidence of the fault codes re-occurring.
 

Flying Spanner

Registered User
Lost comms will be a fault within the ABS ECU. Open it up and solder a jump wire where the tiny link from pin to board has broken. If you don't want to do this either buy a new one or send it for repair.

The brake circuit F on someones log means the contact for pins 2 and 3 in the switch are open circuit sporadic, you may also have brake lights stuck on all the time due to a fracture by the tiny rivets which causes the tension in the switch to fail. You could also get this fault if both brake bulbs have blown (more so on A4) but centre high level light works. It will log a fault and flash glow lamp if its a diesel. These switches are rubbish but they have finally changed the design to one which wont fail, so get yours changed if its pre 4F.
 

enda1

Registered User
Sent the ABS module to BBA-reman and got it back on friday. Fitted it on Saturday and scanned with VAgcom. All problems solved. Very impressed with BBA-remans service and a good price
 

maxlbrown

Deep Blue
NOte

If you can read the fault codes with the ECU still plugged iin the problem is not the standard power issue which is known.

If you cant read the Fault codes then the it is certainly the known fault in which the power circuit fries inside the ECU.

M
 

ptr2279

Registered User
Dealership says they are able to communicatte with the module as far as coding, but when you start the car it resets back. They said it is the abs module. They also replaced the turn signal stalk.
 
Top