1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ABS and Traction control lights on...

MarLou Jul 27, 2018

  1. MarLou

    MarLou New Member

    8
    1
    3
    Hi all,

    My first question, when I picked up my 2005 1.8T A4 cabrioletit it had the traction control light on permanently, this went off after a day (a new battery was fitted which I think solved it) today after driving around care free. I went back to the car and it now has the traction control and the ABs lights on. Nothing has changed that I know of. It does have a fault with the n/s/f pad sensor that i bridged with a wire to check and proved that the actual pad is at fault not the wiring of the car.
    Any ideas on the abs/traction lights would be greatly appreciated.

    Cheers
     
  2. Avatar

    Google AdSense Advertisement


  3. pauldazzle

    pauldazzle Well-Known Member

    1,224
    100
    63
    Often caused by a failing brake light switch. Only about £1o from Main Dealer, & easy to fit.
     
  4. MarLou

    MarLou New Member

    8
    1
    3
    thanks for the reply, the brake lights etc are all working fine, could
    the brake switch still be a problem?
     
  5. pauldazzle

    pauldazzle Well-Known Member

    1,224
    100
    63
    Yes.
     
  6. MarLou

    MarLou New Member

    8
    1
    3
    Thanks, I shall replace that first and go from there...
     
  7. pauldazzle

    pauldazzle Well-Known Member

    1,224
    100
    63
    You should really get it read for fault codes, but brake switch failure is common on VAG cars from that era, & puts the ABS, & Traction Control lights on.
    I've had to replace it on a few of my VAG cars in the past.
     
  8. DieselJake

    DieselJake Well-Known Member VCDS Map User

    3,316
    923
    113
    If your anywhere near Birmingham I've got vag com.

    Probably unrelated (especially with the good weather) but I had this before; https://www.audi-sport.net/xf/threads/1-9tdi-not-starting.374890/ started with lights and ended with limp mode then a car that wouldn't start down to water corroding the electrical components.
     
  9. MarLou

    MarLou New Member

    8
    1
    3
    Thanks for the offer DieselJake but im in Windsor so a little to far, Ive got a mate with a reader who is coming round, last time it was read it said steering angle sensor so not sure if this is linked, everything else was clear, although that was the day before the lights came on....
     

Share This Page