1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A6 C6 2010 - Replacing reverse lights

A6JP Oct 30, 2016

  1. A6JP

    A6JP Member

    66
    9
    8
    Hi all, I want to replace my reverse bulbs with Cree LED's. Does anyone know which bulbs I need. Every website I am using is saying to replace with 382 bulbs but I am thinking that is incorrect for some reason.

    Pic below of the lights I have.
     

    Attached Files:

  2. Avatar

    Google AdSense Advertisement


  3. Steveredman

    Steveredman Active Member

    418
    107
    43
    You may well have the same problem I did, the cold diagnosis function will pulse the bulb and cause it to strobe whilst you are driving along. There does not seem to be a fix for this.


    Sent from my iPhone using Tapatalk
     
  4. A6JP

    A6JP Member

    66
    9
    8
    Hi, i have no problems, just want to replace the bulbs as I have installed Cree's on every car I have owned as they produce a very bright light for reversing. The standard ones dont produce hardly any light.
     
  5. Simon968

    Simon968 Active Member Team V6 TDi Audi A6 Audi Avant Owner Group S-line owners group

    363
    51
    28
    I fitted Cree reversing light LEDs on my Avant and they flickered every few seconds when not in reverse due to the the bulb check as Steveredman suggested.
    You won't have that problem with normal filament bulbs, but you could with LEDs, even CANBUS friendly ones.
     
    A6JP likes this.
  6. Steveredman

    Steveredman Active Member

    418
    107
    43
    I meant that you will most likely have a problem once you've installed them. I installed some on my reversing and indicator lights, they worked beautifully and gave no errors on the dash, problem was that the strobing at the back made my car look like a police car! I do not think there is a way to disable or bypass this and I have looked into it. If you do find a way please let me know as I much rather have the clean bright light from the LEDs. The bulbs you want are most likely W16W, or at least that is the type in the Avant.


    Sent from my iPhone using Tapatalk
     
  7. A6JP

    A6JP Member

    66
    9
    8
    Oh right sorry, well if thats the case then its probably easier just to leave them alone. So annoying as i rest my foot on brake when reversing to create more light.

    I found the below on ebay just a second ago, might try them but unsure as I dont want the flicker as they will just burn out after a while and if they flicker they will annoy other people as they are very bright.

    https://www.ebay.co.uk/itm/182098871043
     
  8. Steveredman

    Steveredman Active Member

    418
    107
    43
    I don't think they will burn out, I think LEDs are more robust in that way, it's the flash every 30-60 seconds that's the problem, shame there is no way to code it out.


    Sent from my iPhone using Tapatalk
     
  9. A6JP

    A6JP Member

    66
    9
    8
    Massive shame as the rear indicators and reverse lights are terrible on my A6. Might just replace with some quality replacements.

    I just looked what phillips and osram do for w16w LEDs and they both have some good products, might try one of them out as sometimes good quality bulbs dont tend to cause issues. Its the parting with £20 on 2 bulbs that might not work correctly/flicker thats the issue.
     
  10. Steveredman

    Steveredman Active Member

    418
    107
    43
    Just to be clear, it's not the bulb that causes the flicker, it's the car. The A6 tests all the bulbs on a cycle whilst the car is on. It does this by sending a short pulse to test the circuit is closed. The relatively long switchon time of the halogen bulbs makes this invisible. LEDs switch on instantly and therefore the test pulse creates a visible flash. I don't think the quality of the LED bulb will make any difference to this. I have a pair of Philips Silvervision indicator bulbs on the rear which seem much brighter and clearer than the ones I replaced them with.


    Sent from my iPhone using Tapatalk
     
  11. A6JP

    A6JP Member

    66
    9
    8
    I might have to gove those a try, shame about the LED's, i really wanted the crisp white reverse. Thanks for your help. Probably saved me £20.
     
  12. Avatar

    Google AdSense Advertisement


  13. KrisKrk

    KrisKrk A6 C6 4F 2010 LeMans Avant Gold Supporter TDi Audi A6 Audi Avant Owner Group S-line owners group Manual Le Mans Edition

    2,223
    2,180
    113
    Same here.
    Replaced reverse ones on my avant and it does flash from time to time.
    Recently replaced fogs does the same and got resistor inline.
    It cannot be avoidedor decoded, been told here and for that reason will not change indicator bulbs.
     
  14. Steveredman

    Steveredman Active Member

    418
    107
    43
    It's a shame as they look so much better, it irritates me that the wing mirror indicators are not synced with the bulbs (perhaps I'm a bit OCD). I even looked into using a capacitor to absorb the short voltage spikes but I think it's just over complicating things


    Sent from my iPhone using Tapatalk
     
  15. KrisKrk

    KrisKrk A6 C6 4F 2010 LeMans Avant Gold Supporter TDi Audi A6 Audi Avant Owner Group S-line owners group Manual Le Mans Edition

    2,223
    2,180
    113
    Won't capacitor need to release accumulated voltage at some point.
    I studied electronics in the past and understand basic's, as for capacitor but maybe I'm wrong?
    If it does, where it will go? Flash again?
     
  16. Mollygoogle

    Mollygoogle Member

    290
    15
    18
    It's a real shame as this is the start of my first winter with this car and despite having done 14000 miles in six months I've almost never driven it in the dark and only now realise how bad the reverse lights are
     
    A6JP likes this.
  17. B5NUT

    B5NUT Well-Known Member TFSI Owners Group VCDS Map User Audi A6 Audi A3 Audi Avant Owner Group quattro S-line owners group S tronic

    4,431
    958
    113
    You won't be able to modify the indicators, the indicator in the mirrors and not run off the same circuit as the one in the headlights, there is a can signal from the central electric module which communicates to the door electric module, which then activates the turn signal in the mirrors.
     
  18. A6JP

    A6JP Member

    66
    9
    8
    At least im not the only one with the same problem, haha.
     
  19. Crossmax

    Crossmax Member

    162
    10
    18
    Can anyone recommend a bright set of normal bulbs to replace my reversing lights with?
     
  20. vajkooo

    vajkooo New Member

    1
    0
    1
    Did somebody solve the problem with flashing LED reverse lights?
     
  21. KrisKrk

    KrisKrk A6 C6 4F 2010 LeMans Avant Gold Supporter TDi Audi A6 Audi Avant Owner Group S-line owners group Manual Le Mans Edition

    2,223
    2,180
    113
    In the end, I have replaced indicator bulbs and they also strobe when ecu does it’s bulb check every 30sec.
    Difference in light wasn’t big but after finding right bulbs, I am more than pleased.
    Waiting for a second par of resistors to arrive, as read online that, fitting them to all 4 indicators may or should solve the problem of strobe effect.
    Rear one did not need resistors when first fitted leds and they didn’t threw any error. Will add them on as a matter of curiosity.

    Awaiting another set of bulbs to replace current reverse bulbs, that supposed to be much brighter than current ones.

    Nothing could and was done to solve strobe and doubt anyone would he ever to do.
    Been told by “bulb site sponsor” that our C6’s are special and more complex as supposed to fitting any led bulbs and would need some additional drivers to wired in, to prevent strobe.
    Haven’t been given any more details as gave up waiting for he’s bulbs.

    At the moment, my car rear strobe from majority of lights




    Sent from my iPhone using Tapatalk
     
  22. KrisKrk

    KrisKrk A6 C6 4F 2010 LeMans Avant Gold Supporter TDi Audi A6 Audi Avant Owner Group S-line owners group Manual Le Mans Edition

    2,223
    2,180
    113
  23. KrisKrk

    KrisKrk A6 C6 4F 2010 LeMans Avant Gold Supporter TDi Audi A6 Audi Avant Owner Group S-line owners group Manual Le Mans Edition

    2,223
    2,180
    113
    Just had my led number plate lights strobe fixed with 5 pin relay and resistor.



    Computer bulb check does see load from resistor but leds are not connecter to strobe with impulse. When relay is triggered, leds are working and computer still read load from resistor. Clever

    Wiring diagram:

    [​IMG]

    Will attempt to resolve strobe issue on reverse lights and all indicators with front fogs, at later stage


    Sent from my iPhone using Tapatalk
     
  24. Mr DJ MOORE

    Mr DJ MOORE Member

    63
    15
    8
    My car had LED reverse lights in and did the same so I went back to the old bulbs to test it. As they work and haven't given me an issue (yet) I will leave them be
     
  25. KrisKrk

    KrisKrk A6 C6 4F 2010 LeMans Avant Gold Supporter TDi Audi A6 Audi Avant Owner Group S-line owners group Manual Le Mans Edition

    2,223
    2,180
    113
    Did same to reverse lights as to number plate and it does solve the strobe. No error on the dash either.
    However, occasionally I get dash error for reverse lights when reverse gear is engaged. sometimes after few seconds and sometimes non at all. Don't know yet why it is happening but will investigate.
    There is a power control unit under the steering wheel column trim which distributes power to all indicators, fogs, reverse and number plate lights. Might fit larger box in there with all relays and resistors for each light instead of doing it individually. Once figured out the issue with intermittent dash error for reverse lights and if space under the trim will allow me for box I want, will report back and post it on my "Quick one" thread.
     

Share This Page