A6 Avant Relay Issue

Matthew Black

Registered User
I have a 2005 A6 Avant that's having some electrical problems. Heater keeps working and not working sporadically, a few lights on the dash keep appearing and disappearing, the indicator light doesn't flash when indicator is pressed (is stays on as a constant rather that flashing).

Someone said it may be a relay fuse. Any ideas?

Thanks
 

Alex jb

Registered User
If indicators flash fast it used to be an sign that a bulb had gone, no flash just constant would suggest flasher relay.
There’s loads of YouTube vids of how to get the hazard switch apart, it contains the hazard flash and indicator flash relay, it seems to be the contacts that fur up and can be cleaned, or if it’s worse, may be worth getting a new switch.

Heater, is it the heat that is intermittent or the actual fan/blower?


Sent from my iPhone using Tapatalk
 

Matthew Black

Registered User
Thanks. I took the hazard box out, had a bit of a fiddle and the indicators work as expected now.

The heater blower works sporadically .The heat is fine when the blower works.
 

Alex jb

Registered User
May be another relay, or could be the blower motor itself. Not as sure on that one.


Sent from my iPhone using Tapatalk
 

Matthew Black

Registered User
It was doing it a couple of weeks ago. I called the AA because I felt driving without a flashing indicator was unsafe. The AA guy disconnected the battery after which the blower worked fine again. He mentioned a dodgy relay or perhaps damp in a relay box or electrical circuit and hence why some other lights are coming on intermittently.

It's a bit annoying (and cold) at this time of year. Glad to have the indicator sorted though
 
Top