1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4/S4 B5 Avant brake bulb dash warning lamp issue

BumbleB Nov 20, 2018

  1. BumbleB

    BumbleB New Member Team Imola Audi S4 Audi Cabriolet Owner Group

    7
    0
    1
    Hi, I'm new on here and am looking for some help with my 1999 S4. I did a search for this topic first but couldn't find a thread, hence this new post. The brake bulb warning lamp comes up on the check system continuously. In fact it is on most of the time - which is the less frustrating as sometimes it keeps going off then coming on again when driving (without touching the brakes), when of course it beeps and is highly annoying! All the bulbs are working, even the third brake lamp bulbs, so I'm not sure what is causing this unless there is maybe a grounding issue somewhere. Has anybody experienced this before or is there an auto electrician out there that can point me in the right direction? Thanks.

    :yellowrs4:
     
  2. Avatar

    Google AdSense Advertisement


  3. Leo Komninos

    Leo Komninos Member

    84
    21
    8
    Yes, had a sporadic bulb failure warning on my b6, was switching between rear right brake and centre brake. Cleaned contacts for rear right cluster, and put new good quality bulb in, and all good. Had previously use emergency bulb from kit, suspect resistance caused false positive on the warnings. Also expect your nimh batteries to expire for the alarm siren which are housed in siren in rear right lower corner, inside. Have noticed not only my 2003 A4, but also my 2001 Saab having same issue. Must have been due...

    Sent from my G3121 using Tapatalk
     
  4. BumbleB

    BumbleB New Member Team Imola Audi S4 Audi Cabriolet Owner Group

    7
    0
    1
    Thanks Leo, I'll check the light cluster contacts and bulb qualities and post when done.
    Just ordered a new alarm siren this afternoon :thumbs up: Need to replace the wiring loom contactor for it as well :sadlike: You must be psychic :haha: Thanks again.
     
  5. AlexA4Avant

    AlexA4Avant Active Member

    688
    121
    43
    Check the brake switch on the pedal as it has 2 in built contacts and 4 pins so I would have that as it is only cheap from euro car parts

    Sent from my FIG-LX1 using Tapatalk
     
  6. BumbleB

    BumbleB New Member Team Imola Audi S4 Audi Cabriolet Owner Group

    7
    0
    1
    OK, so I have cleaned the contacts for all bulbs in both rear light clusters with cotton buds and electrical component cleaner and replaced both brake light bulbs, to no effect. (Contacts looked clean enough prior to my intervention BTW).
    I'm going to source a brake light switch and renew that before tackling the high level brake lamp.
    Thanks for the tips guys.
     
  7. russell.hammond

    russell.hammond New Member

    19
    0
    1
    I had the same problem and it turned out to be the cluster.

    Can you swap and test?


    Sent from my iPhone using Tapatalk
     
  8. BumbleB

    BumbleB New Member Team Imola Audi S4 Audi Cabriolet Owner Group

    7
    0
    1
    Hi Russell, thanks but do you mean swap the rear lamp clusters or instrument cluster?
     
  9. Leo Komninos

    Leo Komninos Member

    84
    21
    8
    Either way it would be the contacts. Learnt from owning an Alfa, it's worth buying some electrical contact cleaner spray.

    Sent from my G3121 using Tapatalk
     
  10. BumbleB

    BumbleB New Member Team Imola Audi S4 Audi Cabriolet Owner Group

    7
    0
    1
    Thanks Leo. Yes, already cleaned the bulb contacts on both rear lamp clusters with electrical contact spray. I'm working my way through the possibilities suggested.
    Cheers.
     
  11. russell.hammond

    russell.hammond New Member

    19
    0
    1
    Sorry I meant the instrument cluster.


    Sent from my iPhone using Tapatalk
     

Share This Page