A4 B7 2.0TFSI, No power and PCV issues

Svengard

Registered User
Hi all,

A few month ago I bought a 2004 A4 B7 2.0TFSI, 111k on the clock and a service history up to 105k.

The problem is that the car is leaking power. Before I got the car the PCV valve was replace from a Audi garage (April 18), but as soon as I open the oil cap or pull out the oil stick, the engine is sucking air and starts to idling very bad. I am not sure if they replaced the tubes too. Last weekend I checked the connection of the tubes and even took out the valve to have a look, but to be honest I was not sure what to look for and I know a bad PCV could cause the systems.

The car shows no errors and no lights are on, on the dash.

I also heard that the diverter valve like to go bad or at least the old versions of it. I haven't checked that yet. That could be the issue for the lack of power, but not the sucking air issue.

Does someone has any tips what the issue could be or point me in the right direction?

Thanks
 

I'm Just Rob.

Moderating or something,
Staff member
Moderator
VCDS Map User
Gold Supporter
The DV is a very common point of failure on these engines, high milage is not a key factor as the earlier type can go at any time really , it is the nature of the design, newer type are better .
You wont get any errors or lights on the dash for a DV failure or failing, classic sign's are lack of power and very poor boost.

PCV is a problem area full stop, best plan would be to get rid of it all together really but if not, make sure all the pipes are clean and the valve is the newest type .
If you have poor idling and the cap is really hard to get off then that does indicate a problem with the pcv, or you have a blockage .
 

Svengard

Registered User
Hey Rob, thanks for the reply.

I try to have a look at the DV soon. I think the only way to access it, its from under the car right?

When I open the oil cap, I can hear air leaking from the rear area of the PCV. Do you think the O-ring of the pipe could be bad? I was thinking about to replace the pipes, but the longer on at the rear looks like a pain to replace.

Deleting the PCV is a good idea, but do I got any issue MOT wise or any issue with light on the dash after the delete? Do you have any recommendation for a delete kit? I found cheap ones on ebay for 35£ but also Forge ones for 90£.

Thanks
 
Top