1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 B6 steering wheel control module coding

chris_90 Apr 12, 2016

  1. chris_90

    chris_90 Member

    42
    7
    8
    Now ive searched the Internet over and over with this to make sure I get it right so I'll start at the beginning.

    I bought a cruise and trip conputer stalk fitted them to find I have the wrong control module but got the trip working. Ive bought a second hand control module right one to control the cruise, fitted it gone to code it but it will not accept the code for abs still keeps going back to 00000 so tried the learning vin number think on stearing wheel section on channel 81 putting in 00111 save it and try coding again but still no joy really dont no were im going wrong I checked the coding before removing making sure I put the right code back in (04255) so I know the code is right.

    Can some one point me in the right direction as im getting no were?

    To top it off put the original one back in and I cant code that it exact same issue so rules out it being faulty as it worked fine before removing.
     
  2. Avatar

    Google AdSense Advertisement


  3. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    Could you post a full scan, with fault codes, so I could compare to mine. I recently fitted CC to my b6 cab so might be and to help.

    Also attach any old scans that you may have saved to compare with.

    Matt
     
    Last edited: Apr 13, 2016
  4. chris_90

    chris_90 Member

    42
    7
    8
    I might be able to but it'll be difficult as im using a mates vag com to do it so have to be at his to get the fault code lists.
     
  5. chris_90

    chris_90 Member

    42
    7
    8
    If I remember correctly the 2 codes were control module no coded correctly and steering angle sensor, id have to double check but sure that was it.

    I even changed the work shop code 12345 and the other 3 digit number to 444 with no avail, no matter what I do it just wont accept the code for abs im 99% sure its the right code because its the same as what was on the old module
     
  6. chris_90

    chris_90 Member

    42
    7
    8
    So ive been in touch with a vw/audi specialist today and they've told me its a main dealer job only? Surely this isn't true?
     
  7. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
  8. chris_90

    chris_90 Member

    42
    7
    8
    I had done all them steps but to make sure I tried again going step by step but no matter what it will not accept the code its as if the codes are wrong but the original code was 04255 what translates to 09555 login code really don't no were im going wrong dont no if I should buy a new control module and start again or just give up for now and drive around with the lights on dash
     
  9. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    The code 04255 is for the brakes module. Is it not accepting the brake coding or the steering module coding?
     
  10. chris_90

    chris_90 Member

    42
    7
    8
    Not accepting the brake coding, and when I do go to steering angle sensor says error anyway
     
  11. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    Tbh mate without seeing I'm not sure what is happening with it. Maybe go to Audi and see what they say. It all worked for me with that guide
     
  12. Avatar

    Google AdSense Advertisement


  13. chris_90

    chris_90 Member

    42
    7
    8
    What do u think it'd cost me at audi? Id rather sort it my self tho, im following the guide to the letter, when I go to abs section I login with 09555 then enter code 04255 then in the top corner it says something like login lost due to dropped session, its as if im entering the wrong code but the code from the previous control module (checked before removing it) was 04255 so I don't see why its not accepting it.
     
  14. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    Are you sure that is the login. Just googled and found this

    A "Login lost due to dropped session" warning appears in the upper right corner of the screen if a session is disconnected after you have unsuccessfully tried a Login. You will need to do another Login. The most common cause of this is the use of an incorrect login code or a 7-digit PIN/SKC based on an incorrect Immobilizer ID or incorrect data entered in the 7-digit dialog.

    It says it on a vcds "lite" page. Are you using full vcds and if so which version, or is it vcds lite?

    I'll have a look at the appendix later to see if the login looks correct
     
  15. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    What car is it on?
     
  16. chris_90

    chris_90 Member

    42
    7
    8
    04255 was the code that was there when I first looked before removing control module (see pic I attched), the car is a A4 b6 1.9 tdi (awx).

    From building the codes im 90% sure its the right code but its making me think im wrong because of it saying session dropped
     

    Attached Files:

  17. chris_90

    chris_90 Member

    42
    7
    8
    Still stuck on this still wont code any help any one?
     
  18. chris_90

    chris_90 Member

    42
    7
    8
    So ive fitted a highline steering wheel control module still wont code, im at a complete lose now only thing I can think of is that my mates vag com isnt genuine.

    Ive spoken to audi dealer about it and he wasn't much help as because of the age of the car there's not much information on there system for it, he did say that they can have a look at it for me at the cost of £60 but there's no grantee that they can code it so could just be wasting more money.

    Heres a couple of pics of fault codes
     

    Attached Files:

  19. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    Vcds 12.12. non genuine. Chinese cable. Can cause more problems than fix.
     
  20. chris_90

    chris_90 Member

    42
    7
    8
    I hope I can find some one with a genuine cable to help me out and hope that fixes it. But struggling to find some one at mind
     
  21. Kieran_Gray

    Kieran_Gray Member

    32
    4
    8
    Hi Chris,

    We are in the same boat... I've just fitted cruise and DIS to my b6 A4, went to see Liam last night, but it wouldn't code.

    After some research turn out my steering wheel control module doesn't support cruise! - just ordered a highline one.

    We could both meet at Liams one night and code them together? - I just live round the corner from him :)
     
    chris_90 likes this.
  22. chris_90

    chris_90 Member

    42
    7
    8
    Ive tired two different control modules now with no luck so hopefully the genuine vag com will code it, id be happy to meet at same time if its possible to arrange it, but its a struggle with my shift patterns as i work random shifts each day.
     
    Kieran_Gray likes this.
  23. Kieran_Gray

    Kieran_Gray Member

    32
    4
    8
    Let me know what suits you mate, I am home every day at 16:30~

    The coding should only take 15mins per car!

    Would love to get mine work by next Thursday as we are driving to Cornwall :)
     
  24. chris_90

    chris_90 Member

    42
    7
    8
    Yer coding doesn't take long neither does fitting it, I have my cruise and trip computer working its just the abs coding that's the issue you will find this out when you change the module, I've been driving around for the last 1500 mile with esp,abs permanently on handbrake warning light flashing and brake light on the LCD display flashing starting to great on my now. Trying to organise a meet time now with Liam but not got my rota for next week yet.
     
  25. Kieran_Gray

    Kieran_Gray Member

    32
    4
    8
    Might have to give you a shout when I change my module this week!

    Did you have to ground pin 1 behind your clock set for the washer bottle level light?
     
  26. chris_90

    chris_90 Member

    42
    7
    8
    Yer I did was simple to do tho took a couple of mins. I took clocks out what made it easier
     
  27. chris_90

    chris_90 Member

    42
    7
    8
    Ive now got this sorted. With genuine vag com it coded right away. Defiantly considering buying a genuine one now!

    Thanks for everyone help
     
  28. mattmanwrx

    mattmanwrx Used to have a wrx. Now an S4 VCDS Map User

    471
    197
    43
    Glad it is now sorted. Always use genuine. The non genuine could cause more problems, as we've seen, or even damage.
     
  29. Wahlstrom

    Wahlstrom Active Member

    513
    173
    43
    I’m going to upgrade my module tomorrow from Q version to R version, for adding heated steering wheel.

    So I’m gonna make a complete scan to get all coding values.
    From what I can read, since it second hand, I need it to learn the VIN number and the record it to my coding but change the value for heated steering, and that should be it..
    Or do I have to go through all connected modules, esp and angle sensor calibration?
     

Share This Page