A4 1.9TDI Starting + running problems - HELP!

col6821

Registered User
A friend of mine has a 2004 A4 Avant 1.9TDI Auto with 155k miles that’s not running at all well and he needs some advice...
Basically the engine isn’t running smoothly, and usually refuses to start from cold without having carburettor fluid sprayed into the air intake. This issue appeared 2 weeks after having the head gasket replaced, and so far additional parts that have been replaced are:-
Fuel filter and high pressure fuel pump
Low pressure fuel pump
Injector wiring harness (damage caused when replacing head gasket)
Repair to other engine bay wiring (unsure what, but the garage carrying out the repairs found it)

If the car is parked nose down, the chances of it starting are better, but it still doesn’t run smoothly, whilst parking it nose up ensures that it won’t start without carburettor spray.

The garage have been really good so far as attempting to repair, but after 6 weeks of trial and error, there has to be a limit. They are now saying that it could be a fault with the dual mass flywheel, is this possible? Has anyone experienced any issue such as this before? Also, does anyone know what can be classed as reasonable endeavours by the garage, before moving on for a second opinion as to what may be wrong? So far the head gasket and high pressure fuel pump have been the only work paid for, but the problem persists.
Any help greatly appreciated.
 

adamss24

Registered User
I would fit a new injector wiring loom- about 40 quid from dealer- and i will check for perished rubber hoses from the fuel filter to the engine/tandem pump. Also, i presume that the lift pump in the fuel tank is working when the ignition is cycled on ? If not, i would trow a new fuel pump relay and check the fuses as well. Also make shure the fuel filter is genuine or has not been replaced recently. they have a plastic one way valve wich lets the fuel drain back to the tank when faulty... Hope this helps.
 

paul20v

Audi fanatic
The 1.9 PD doesnt have a high pressure fuel pump only a low pressure feed pump to the injectors so what did the garage change ?
 

BILKO1

Registered User
The 1.9 PD doesnt have a high pressure fuel pump only a low pressure feed pump to the injectors so what did the garage change ?

It does have a highish pressure pump Paul20v it's on the end of the head driven by the camshaft it's called a tandem pump as it's also the vacuum pump for the brake servo.
 
Last edited:

paul20v

Audi fanatic
It does have a highish pressure pump Paul20v it's on the end of the head driven by the camshaft it's called a tandem pump as it's also the vacuum pump for the brake servo.
Im not looking for an argument im genuinely intrested as too how the Brake vac pump also is a high pressure diesel pump ?


My understanding and of working on PD engines is that the fuel is pumped from the tank by a low pressure system to the injectors which have there own individual high pressure diesel pumps integral in the injector that then get opperated via the cam and fired with a solenoid
there is no other high pressure pump in the system the injectors are there own pumps hence the name of the engines "Pumpe Düse", or "PD".
 
Last edited:

BILKO1

Registered User
Top