1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

A3 Cluster and Heating Controls not working

Chris1982 Nov 30, 2019

  1. Chris1982

    Chris1982 Registered User

    6
    0
    1
    Hello, I hope I’m posting this in the right section, please move if it’s not right.

    Audi A3 2.0 TDI 107k 2008.

    3 weeks ago my cluster display and heating control stopped working. The car runs fine expect for this. Loads of lights stayed on whilst driving, lights that would usually go out when I start. The heater still worked if I shone a torch at the display just wouldn’t light up.

    I spoke to a few garages and cluster repair online and they all said cluster is gone needs repairing. So I found a company online with decent reviews that would repair for £150. I was going to send it then 2 weeks ago the heater display came back on and then the next day everything came back on and worked as normal.

    it didn’t last because yesterday it’s all off again :( I’ve checked the battery and fuses and it’s fine.
    Is there anything I can check myself before taking out the cluster? Does it sound like the cluster is faulty or do I have a dodgy connection somewhere? Also is the cluster display and the heating panel related?

    thanks in advance for your replies.
     
  2. Avatar

    snack-media
    Advertisement


  3. Matt268uk

    Matt268uk A3 Sportback VCDS Map User

    933
    194
    43
    A scan with vcds is probably a good idea to start with. Check out the user map to see if there’s anyone local that could do it for you. If your concerned that your cluster has had it you can buy these from here from time to time. You could put an add in the classifieds under wanted or look on ebay but you’d probably be looking at around £30 and not the £150 you’ve been quoted for a repair.
     
  4. Chris1982

    Chris1982 Registered User

    6
    0
    1
    Thanks for your reply.

    I did look about buying new clocks, they are pretty cheap on eBay but then I read they need to be mapped to the car and mileage etc and that can cost whereas £150 to repair my existing and straight swap, in theory.
    I guess a scan is a good start but then again I read the code tells you you’ve a faulty cluster which I already know. Garage around here charge £50 just to put it on the machine, maybe I need to search as you said.

    Is the cluster display related to the heater control display?
     
  5. Matt268uk

    Matt268uk A3 Sportback VCDS Map User

    933
    194
    43
  6. Chris1982

    Chris1982 Registered User

    6
    0
    1
    Thanks again for your reply.

    Went back out this evening and everything back on again which makes me think it’s not a faulty cluster and rather a faulty connection/module somewhere along the way. Is there a module or something I can unplug and check the connection is ok? I know I need to get it read but I’m thinking of things I can check first.
     
  7. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    31,784
    2,335
    113
    It doesn't sound like a cluster or hvac issue, I'm thinking ignition switch tbh, but until seeing the car is not be sure.
     
Tags:

Share This Page

Do Not Sell My Personal Information