A3 2.0 Tdi 2004 Fan Replacement.

gizm0

Registered User
Hi all, my girlfriend fan has been coming on whenever she drives the car. i am finally going to sort this now lol.
It is just the large fan out of the two that is running. am i right in saying its just that fan that needs replacing? i have had the unit apart and found the part number for the single fan.

i have read that it is something in the fan unit itself that fails. has anyone had any luck in actually repairing it?

Thanks in advance.

Dan
 

bigal23

Registered User
does it come on full all the time when the aircon is on and as soon as aircon is turned off it goes off?
 

screechmr2

I love beer
are you saying the little fan doesn't run so the big fan runs flat out for about 20 secs slows down, then a couple of minutes later runs flat out again?
 

screechmr2

I love beer
is the little fan working at all? If not I'm guessing you're on about about replacing that and not the big fan which is working and doing the job of two fans so having to work extra hard
 

gizm0

Registered User
It is the big fan that is constantly running at full rate after two minutes of driving the car, nothing to do with the zircon fan. that is fine as and when it is needed. there is a common issue where something in the large fan breaks down and causes it to run constantly. I was just hoping you can get the large fan its own but I've found out tonight that the only single replacement fan that i can find (euro car parts) doesn't fit so i will be fitting the whole unit with two new fans tomorrow now to cure the issue.
 

SmithyAG

Registered User
Fan controller is located in the large fan, however when it goes it usually causes both fans to run full speed constantly even after engine shut off (well mine did at least).

I also found no replacement fans available separately, had to replace the whole lot.
 

bigal23

Registered User
mine happened after I replaced coolant sensor the large fan just runs constantly full speed with aircon on small fan never kicks in at all. these fans are odd
 

gizm0

Registered User
WELL... yesterday I got a single replacement large fan from euro car parts which they said was a direct fit. Turns out it didn't fit so while the old fan was out I removed the rear cover and took it apart and it was caked in dust and **** so I took it apart and sprayed electrical contact cleaner. Worked the brushes in and our and scrubbed it with a light brush and generally gave it a good clean up. Put it back together and so far it hasn't kicked in like it usually does! Engine temps are staying good so fingers crossed it may have sorted it!
 
Top