80mph limp mode

LloydMF

Registered User
Hi all,

Hoping someone can help me out here...

For a while now I've had very intermittent limp mode issues. The car is absolutely fine to drive 99% of the time, the 1% however is on some occasions when the car is in 5th doing around 80mph (especially when accelerating around this speed) it suddenly has a massive reduction in power which means i need to restart the car for it to work as normal again. No engine lights, just passed MOT with no advisories and like i say almost all of the time it drives fine.

Once the issue happens and I've restarted sometimes it happens again on the journey other times it doesn't.

I've used Revive turbo cleaner on it twice now to no effect (although lower end pick up has improved which is a plus).

Any help would be amazing before i go see a garage and they charge me a fortune.

Thanks in advance,
Lloyd
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
Hi all,

Hoping someone can help me out here...

For a while now I've had very intermittent limp mode issues. The car is absolutely fine to drive 99% of the time, the 1% however is on some occasions when the car is in 5th doing around 80mph (especially when accelerating around this speed) it suddenly has a massive reduction in power which means i need to restart the car for it to work as normal again. No engine lights, just passed MOT with no advisories and like i say almost all of the time it drives fine.

Once the issue happens and I've restarted sometimes it happens again on the journey other times it doesn't.

I've used Revive turbo cleaner on it twice now to no effect (although lower end pick up has improved which is a plus).

Any help would be amazing before i go see a garage and they charge me a fortune.

Thanks in advance,
Lloyd
Which car do you have? Do you have the ability to read fault codes?
 

LloydMF

Registered User
It's an audi a3 2.0 tdi sline

I don't personally but a friend ran it recently and i believe it read as an overboost error can't remember the exact code - can't imagine that helps!
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
It's an audi a3 2.0 tdi sline

I don't personally but a friend ran it recently and i believe it read as an overboost error can't remember the exact code - can't imagine that helps!




The car can enter to the Limp mode for several reasons. Reading the fault codes Very important in the diagnosis process
 

studunc06

Registered User
Without knowing the code you got, i would guess at the vacum unit on your inlet manifold, if the code was a p0029 or something like that, reasonably cheap and easy to fix, i had a similar issue a while ago.
 

desertstorm

Moderator
Staff member
Moderator
VCDS Map User
limp mode on diesels can be caused by a few things and other than replacing things randomly there is no knowing what is causing the issue.
May be a faulty MAP sensor, easily determined by checking boost levels in the measuring blocks. Possibly VNT mechanism coked up. difficult to tell from just logs alone but it may give you a clue.
Faulty N75 valve, again difficult to tell from the logs but it should give you an idea.
This is assuming the fault is due to overboost, underboost can add other things that could be causing the issue.

Karl.
 
Top