Gateway Module Update -> CP Activated. Help pls!

yakev724

Registered User
Joined
Aug 14, 2021
Messages
25
Reaction score
2
Points
3
Location
New York
Hi,

I have a 2015 S3 and have successfully completed the MIB2 retrofit. This led to some of my steering wheel buttons no longer working so I fit an FL steering wheel and needed to update the gw firmware to allow the new buttons to work. Unfortunately flashing to the 'AM' firmware resulted in CP becoming active on the gateway!

Is there something I can do to remove it/move forward? My ADS has been disabled since flashing as well (MMI menu nit available, dash button does nothing), would like to re-enable this, presumably needs to be re-activated in gateway somehow. Please help! I'm stuck - any references to remote services who can help much welcome as well. Or if I can book time at my dealer to remove CP/update firmware maybe that route worth exploring? TIA
 
Dealer visit for cp, but you already knew that ;)
 
  • Like
Reactions: 8YARWY and yakev724
Thanks for confirming will book some time w my dealer.

Given my MIB2 firmware is 'cracked' is there anything I should ask them to do while my car's in? My understanding is the feature/swap codes haven't been officially added to my car so if they do anything with the MIB2 I'll be worse off, but of course would be great if they could flash official MIB firmware and I'd have 0 error codes in all my modules. Not sure if this is possible theoretically even...

Thanks
 
Tbh you better tell them not to mess with your mib as it could make it unusable subject to what Audi's process is these days.

Specifically I'd say do not touch my other systems, just remove cp on the gateway.

Allot of this is auto so you need to remind them multiple times not to do anything else but the gateway.
 
  • Like
Reactions: yakev724

Similar threads

Replies
15
Views
3K
D
Replies
0
Views
4K
Deleted member 117185
D