Headlight bulb replacement

S3AMJ

OEM+
Joined
Apr 20, 2015
Messages
2,672
Reaction score
1,096
Points
113
Location
Oxfordshire
Evening All,

Noticed last night that one of my high beam bulbs has gone. Does anyone know which bulbs Trups uses for the high beams? I’m running 5500k colour. Obviously I’ll buy them from his site, just unsure on fitment, etc.

Cheers

Ash
 
Did you not get a set of lights in the last gb? If you did i think the bulbs have a 2 year warranty with them.

No I bought them outside of the group buy mate. If they come with 2 years warranty that’s good. I have messaged Trups, not heard back yet though.


Sent from my iPhone using Tapatalk
 
I'm dealing with him at the moment with an issue with my ballasts. Email him on sales@emtuning.co.uk as he replies better through this.

He'll sort you out
Mate what's the problem with the ballasts if you don't mind me asking.
My driver side light sometimes doesn't turn on it. It takes a couple times turning it of and on for it to come on.
 
Mate what's the problem with the ballasts if you don't mind me asking.
My driver side light sometimes doesn't turn on it. It takes a couple times turning it of and on for it to come on.

It’s my drivers side bulb that’s stopped working funnily enough.....


Sent from my iPhone using Tapatalk
 
Is it definitely the bulb thats blown?
Did u try the passenger side bulb in it to check?

Not yet mate, will check tomorrow if I get time. I’ll see what bulb it is as well. There are several on Trups website, still not heard from from him.


Sent from my iPhone using Tapatalk
 
This is the bulbs that are in mine In case that helps you out to get new ones
20190413 105246
Screenshot 20190413 105332 Gallery
 
Yes mate that is what came in mine. My bulbs where already in the housings when they arrived but Trups sent the empty box's aswell. Which will come in handy when I need new ones. If ur on face book or Instagram you might be able to contact him that way.
 
Yes mate that is what came in mine. My bulbs where already in the housings when they arrived but Trups sent the empty box's aswell. Which will come in handy when I need new ones. If ur on face book or Instagram you might be able to contact him that way.

Ok cheers mate, nah not on either of those. I’ve emailed him and PM’d him on here. I’ll check weather it’s the bulb of the ignitor first. Had to drive it last night, surprisingly still bright with just one bulb working....


Sent from my iPhone using Tapatalk
 
I'm on fb and Instagram. If you want me to message him for you? Where is the ignitor on them so I can see if that's my problem aswell.

Isn’t the ignitor the amplifier? Unless there’s something else? Yeah would you mind messaging him on my behalf, would be a big help :)


Sent from my iPhone using Tapatalk
 
Okay, I can confirm it’s my bulb that’s gone. For those who are wondering it’s the H1 halogen 6500k that I’ve got installed in my headlights.

Hydro, you must have opt for the LED bulbs I wonder how much difference they are.




Sent from my iPhone using Tapatalk
 
Okay, on Trups website emtuning.co.uk

They are the Morimoto XB HID H1 6500k bulbs. Good job they come with 2 years warranty because they are £49 a pair.

Just waiting to hear back from him. Will let you all know the outcome.
 
Last edited:
No prob mate happy to help out. I can't remember what the price difference was for the led bulbs but my thinking was they might be brighter and last a bit longer.
 
Thanks for your help mate, really appreciate it. Wonder if it’s worth changing from halogen to led. Leds generally last longer

I'm slightly confused.....the LED bulbs were only ever supplied by Trups as a 'flash to pass' option, the alternative to this was an ice white halogen bulb so it matched the HID's. The dipped beam and main beam for night driving have only ever been HID (Bi-Xenon).

Is it the bulb in the flash to pass or the main bi-xenon bulb that has gone? The bulb you have quoted off his website is a HID bulb that you can't replace with anything other than a HID bulb because it is powered by the ballasts. If it's the flash to pass bulb you have the option of an LED bulb or a halogen bulb.
 
Mate what's the problem with the ballasts if you don't mind me asking.
My driver side light sometimes doesn't turn on it. It takes a couple times turning it of and on for it to come on.

Sorry haven't been on here for a while. Stopped working altogether and the other one flickers when high beam goes on. He's sending 2 x new ones and I'm sending them both back to see why this has happened. Apparently none have been an issue in 150 sets so quite reliable units. He's been very helpful through all of this
 
  • Like
Reactions: Vex182

Similar threads