Waze, Carplay and Virtual Cockpit


Registered User
May 13, 2012
Reaction score
For the last couple of days Waze has appeared on my Carplay screen, so presumably it is now compatible with Carplay. I put Waze on briefly then turned it off.

Now it appears that whenever I use Carplay the VC shows a compass rather than Google Earth.

Tried resetting and nothing seems to make any difference.

Have done a google search and it appears that this has been previously reported with Waze and Android Auto where they are both running. With me it appears to happen whenever Carplay is on even if I am not using Waze.

Anyone else noticed anything similar or have any suggestions.
That’s correct, when CarPlay is using any Navigation software, it disables the built in nav on the VC!

Apparently there are abilities for CarPlay to take advantage of multiple screens, but I have no idea if that meant the car, or just the car screen then your phones screen (I.e) turns on phone, then Waze map on MMI.

Waze is pretty clunky without a touchscreen!
The strange thing I have found is that I wasn’t using Waze or any navigation at all just wanted maps on so I could see traffic ahead, I have removed it from CarPlay and will see if that sorts it.
Ah! Then it just recognised you had some nav software in CarPlay at some point, make sure you swipe close the apps on your phone, or if you start a navigation route from MMI it will override CarPlay and then show the map on VC
  • Like
Reactions: hmy7k
Tried it again today and as soon as I plug the phone in and carplay starts then navigation on VC switches off.
Thats even with no navigation options running on Carplay.
If I select a route and then cancel it then it works fine.
My MMI is version 422 is there a later one, I tried updating it but it keeps coming up with an error when trying to find updates.
I can't help with the VC display but I do know owners cannot update the firmware of the MMI. The car needs to be connected to the Audi servers to perform this, usually at a dealership, but why that setting is in the menu and not a hidden service menu I can't explain.
Yes I had this today also, Waze kindly decided to start automatically when I plugged in my phone, after setting nav destination on MMI.

I’ll try and make sure all nav apps are swiped closed on my way home tonight
Hi, i have similar issues since upgrading to IOS12 and its driving me nuts.

Usually i get in the car, use the steering wheel controls and the VC to select a location to navigate to, then plug in my iphone to play music via Carplay. However as soon as i plug the phone in, the navigation cancels, the compass appears on the VC. I then have to renter my destination using the center controls and main screen, because the steering wheel navigation menu buttons dont do anything. This is while i have no other apps open on my iphone, i have even removed maps and google maps from carplay via the carplay menu under general setting on the iphone.

It is as if carplay has more permissions than the Audi MMI. I can understand the logic if i had the apps open on my phone and had a destination programmed in, but i haven't.

Did you have any luck finding a solution or work around?
The only thing I can add is that my car was in a couple of weeks ago and had an MMI update to stop funny noises from the speakers. Waze / ios12 / Carplay all play very nicely - I only get the compass when Waze is active, then if I close the app I can go back to MMI nav.
I have tried various things but rebooting my phone might have helped.

The last time I used the car it worked properly but I am not holding my breath that it isn't going to come back.
I suspect an update of the MMI is best option.

What is the version that you have now pierreluigi88?
Sorry forgot to reply, I ensured Waze was swiped closed and it did not interfere with the MMI nav.

I seldom use CarPlay for mapping, the MMI does such a good job I tend to just stick to that.
  • Like
Reactions: Gary_LB
Sorry forgot to reply, I ensured Waze was swiped closed and it did not interfere with the MMI nav.

I seldom use CarPlay for mapping, the MMI does such a good job I tend to just stick to that.
I found the same with Waze and IOS12 however as you say, closing the app on my phone resolves the issue
So i think i resolved my issue. My issue was specifically related to google maps appearing on the audi MMI and stopping the audi MMI navigation when i plug in my iphone. Closing the google maps app before connecting my phone didn't resolve the issue.

Within the google maps app i had setup a 'work' location and have the google maps widget enabled (tells me the average commute time at a glance when i wake up). So even though the google maps app doesn't appear to be running, i think it is on some level because of the widget. Disabling the widget option and removing my work location from google maps has stopped carplay interfering with the MMI now.

Not sure if Waze has a similar widget for those of you still having issues. Hope this helps.
  • Like
Reactions: Daggerit