BKD TDI limp mode flutter

nothingness

Registered User
Joined
Jan 30, 2011
Messages
725
Reaction score
124
Points
43
Location
UK
Hi so a few weeks maybe months ago I drove into a layby in Wales doing around 30mph, for some reason they saw it fit to put a curb around this layby which I didn't see. I went over the curb, banged something below where the gearstick is, and went about my day. Later that day my car went into limp mode.

Since then it has been doing it under boost pretty much all the time. I went and had a printout done, something like "limp mode caused by overboost" they explained the turbo is probably on its way out.

I have been toying with the car trying to see whats up and it seems when it goes on boost and doesn't go into limp mode, there is a very loud, sierra cosworth esque flutter noise when you let off...but this noise comes from down where the gearstick / handbrake is.

I am wondering if anyone has any quick ideas as to what this could be?

I am thinking either

blocked or damaged CAT
broken n75 valve?
recirc valve? does it recirc into intake or exhaust?

I hope it is not a turbo. It is booked into an audi dealership this thurs but I would like to avoid the £60 find-fault fee if possible let alone their prices for fixing it.

I have also smelt rotten eggs sometimes but I tend to drive near farms so could be chickens or a dead catylitic converter.

Thanks
 
Could have dented the exhaust pipe? Restricting air flow, or a split this explaining some smells
 
The flutter noise is wierd.

It is booked in to Audi for tomorrow.

I notice I can sort of hear a bit of flutter when I accelerate before it goes into limp mode but again this noise comes from the handbrake area, wierd hearing this through exhaust.
 

Similar threads

Replies
16
Views
3K
Replies
1
Views
669
Replies
4
Views
487
Replies
10
Views
12K
Replies
2
Views
430