1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice
  3. Maintenance work on Tuesday 7th April

    Due to some much needed work to the servers we will be going off line for a couple of hours on Tuesday.

    Sorry for the inconvenience
    Dismiss Notice

Help Please 3.0 TDI (CCWA) oil level warning. Topped up / still on.

mrming Jul 22, 2019

  1. mrming

    mrming New Member

    24
    1
    3
    Hi all,

    Had an oil change on our 3.0 TDI last September. Indy advised me to top up the oil occasionally.

    Was "getting around to it" 9 months later when the MMI "top up oil (1.25 l)" warning (yellow light) came on. Put a litre in it, warning still on. Yesterday bought more oil and put another 500ml in. Warning still on.

    I've ordered a dipstick from my local dealer which I can pick up on Wednesday.

    Am reluctant to keep firing oil in there in case the sensor's knackered and I overfill it.

    Has anyone had this issue before?

    Cheers,

    Phil
     
  2. Avatar

    snack-media
    Advertisement


  3. AndrewW

    AndrewW Active Member Team Sprint S tronic Audi S4 Audi Avant Owner Group

    231
    216
    43
    I had this on the S4, added about 750ml when the warning came on and it didn’t go away. Without having a dipstick I wasn’t willing to put any more in so unhooked the battery for a few minutes and reconnected, it must have reinitialised or something because the warning didn’t come back on and showed close to the maximum on the on-screen oil level thing.
     
  4. mk4gtiturbo

    mk4gtiturbo Active Member Supercharged Team V6 S tronic Audi S4 quattro Audi Avant Owner Group

    104
    37
    28
    I think they are a bit hit and miss. I had my S4 serviced and the garage but the amount of oil required in but the electric gauge only showed half full. I took it back and they put another half litre in but it did not register any change. Only after driving for a couple of days did it all adjust. I have since purchased an proper dipstick!!
     
  5. mrming

    mrming New Member

    24
    1
    3
    Okay thanks both. Sounds like I'm probably okay to drive it for a day or two until I get the dipstick. I knew as soon as I saw the lack of one that it would be trouble!
     
  6. Stonefish

    Stonefish Active Member

    236
    62
    28
    I had a similar problem with my CCWA engine. My MMI kept saying the oil was too low but when I put in some oil it was OK for a couple of weeks before saying it was overfilled. I bought a dipstick and ignore the MMI.
     
  7. PenttisHSR

    PenttisHSR Active Member Audi S4 Audi Avant Owner Group Manual

    145
    48
    28
    OP -It sounds like the oil level has not updated on the MMI.

    To see the current oil level, first the engine has to be at normal operating temp.
    Then switch off and wait for 2 mins.
    Whilst waiting, I open drivers door and open bonnet, then close again.
    Put ign on and correct level should now be displayed in MMI.
    If you see "information not available" either the engine is not hot enough or you didn't wait long enough.
     
  8. mrming

    mrming New Member

    24
    1
    3
    Hi all,

    Some more info. I’ve now got a dipstick and can confirm the oil level is at max after the top up. However the dash warning / MMI is still reporting oil level at min.

    It seems that the oil level sensor has not reset.

    Interestingly, I don’t see a warning on the dash that the bonnet is open. I understand that the car uses the bonnet sensor as part of it’s routine to check that the oil level has changed. Could it be that I have a faulty bonnet open sensor?

    Any pointers greatly appreciated.

    Thanks,

    Phil :)
     
  9. AndrewW

    AndrewW Active Member Team Sprint S tronic Audi S4 Audi Avant Owner Group

    231
    216
    43
    Do you have VCDS, or have anyone local that does? That could help identify a faulty sensor for the bonnet, oil level etc. Could also potentially force a recheck? (Don’t quote me on that last one)

    Shame you’re not a bit closer to me I’d have happily plugged it in and see what came up.
     
  10. mrming

    mrming New Member

    24
    1
    3
    I don’t have VCDS. I do have Carista which can read codes so I’ll try that. It can’t force a re-check though. The car seems to think the bonnet is shut when it’s open and I’ve found a few posts suggesting it’s related to the MMI resetting the oil level.
     

Share This Page

Do Not Sell My Personal Information