Wind noise from Wind Deflectors :(

Arjuanamo

4300K
Joined
Apr 27, 2012
Messages
170
Reaction score
44
Points
28
Location
London
Hi,


So I bought a pair of team heko wind deflectors a few months ago and really like the look of them .

When installing them I never used the metal clips as a few people told me they do more damage than benefit to the Windows .

My only issue is whenever I drive above 40 I can hear a bit of wind noise from the Windows . Does anyone else have these issues ?




Sent from my iPhone using Tapatalk
 
mate i have exactly the same set up and problem, and i use the metal clips. had exactly the same brand on my bmw x5 and they did the same. look good but functionally they are rubbish!!
 
Strange how fashions change. When I was into Mitsubishi's the imported cars often had wind deflectors on and it was the first thing that was taken off. Having said that I have some for the S3 but have not put them because people have reported wind noise.
 
I did get wind noise on the motorway so I took off the rears & now just have the fronts with no wind noise.
 
I have the heko ones and it doesn't make any difference (unless going above 70?)

Are you sure you've fitted them the right way round on the back? I know it sounds ridiculous but it's easy to do (nearly done it myself lmao!!)

Also, use the feking clips...just don't jam them like a madman, leave some clearance but enough for them to sit in there without falling out. You get the gist.
 
Think you get this whatever the car, don't really notice it with my tunes on!

Also I removed my rears as the fitment was proper poor!
 
Yeah the front bows in before you install them so it will be pretty hard to come off once installed . However the back literally just slots in so I can see it falling out and pretty high speeds .


I might try just the fronts on and see if the window noise decreases .

Another issue i have heard of is the 2010 onwards mirrors have a different shape that cause a small tunnel of wind to create noise and high speeds . I remember a few members on here going to Audi for the problem but they didn't have a solution for them .



Sent from my iPhone using Tapatalk
 
I "did" have the same issue of wind noise. I love the look of them, so decided to engineer a fix. I went to hobbycraft and bought an a4 size bit of black felt. I cut it into 1cm strips, applied 3m double sided tape to one side and applied it inside the deflector channel where the window would sit when raised. Perfect job 1st time. No noise at all, seals the small gap that wind had a chance to get through. Quick and cheap fix. Job done!!
 
I "did" have the same issue of wind noise. I love the look of them, so decided to engineer a fix. I went to hobbycraft and bought an a4 size bit of black felt. I cut it into 1cm strips, applied 3m double sided tape to one side and applied it inside the deflector channel where the window would sit when raised. Perfect job 1st time. No noise at all, seals the small gap that wind had a chance to get through. Quick and cheap fix. Job done!!
I’m intrigued about this fix! Could you possibly post a photo of the placement… Many thanks!
 

Similar threads

Replies
31
Views
8K
Replies
31
Views
14K
Replies
3
Views
887
Replies
5
Views
1K
Replies
42
Views
13K