esp light followed by missfire and engine light

Ollie-B

Rockin' Shnit
Joined
Dec 30, 2012
Messages
322
Reaction score
9
Points
18
Location
Stanley, North East, UK
Injector 1 open circuit is the fault and when it clears its fine . i have bought an injector but havnt fitted it yet. i just find it strange that the esp light (trianle with circle - small light) comes on about ten secs before the engine warning light and as soon as its starts to missfire. if i turn off the engine before the engine light comes on it runs fine for a while but once the engine light is on its a constant missfire until the code is cleared. its a 2004 1.9tdi 130bhp. thanks for any advice
 
Could be a broken wire might not be injector try swop injectors round to see if the fault moves cylinders
 
Im gona try swapping the injectors around at the weekend its just intermittent which has me thinking injector is beginning to fail, its the esp light that concerns me
 
More likely to be the injector harness failing, which is very common on PD130's.
 
New harness is about £50 from TPS, & you'll need a new rocker cover gasket.
 
You need to remove the harness with a warm engine as it makes it flexible & easy to pull out, same goes for fitting the new one.
 
  • Like
Reactions: Ollie-B
New harness has cured the problem. didnt fit the new injector as i wanted to see what cured it. thanks for your help lads
 
  • Like
Reactions: pauldazzle
Think the reason your esp light came on is because it's on the same curcit
 
Mine put the traction light on too when I had the same problem so it's normal.
 

Similar threads

Replies
2
Views
640
Replies
0
Views
679
Replies
10
Views
2K
Replies
6
Views
1K