RS3 Grill on facelift S3 8P - Parking Sensors!

cshy85

Registered User
Joined
Jul 29, 2014
Messages
8
Reaction score
0
Points
1
Location
NULL
I've just had the RS3 grill fitted on my S3. Stupidly I didn't do my research on the parking sensors which are mounted in the original grill next to the numberplate. There's nowhere to put them on the new grill! The inner sensors have been taken off which now unfortunately means none of the sensors work and the dashboard button flashes in error!

Has anyone fitted this grill and had the same problem? I can obviously manage fine without the sensors but it would be nice to have the functionality back!

Is it possible to:
1. Drill holes and mount them elsewhere in the bumper?
2. Connect something to the unused harnesses which will allow me to utilise the other sensors somehow?

Thanks
 

Attachments

  • my car.jpg
    my car.jpg
    92.3 KB · Views: 3,441
  • old bumper.jpg
    old bumper.jpg
    100.8 KB · Views: 910
I'm sure when the rs3 grill group buy was on the seller xenons uk had brackets to mount the parking sensors to the grill.
 
Ah yes, it seems I need PDC parking sensor mounts. Not much detail on ones for the S3, only mention of a guy using BMW ones...
 
Trust me the brackets are useless, I used them & as I advised the seller numerous times & ignored me everytime practically, the sensors are recessed to deep into the grill with these brackets & pickup the sides of the grill as an obstacle, I've tested many things & the only fix was to adjust 2 honeycomb sockets with a dremel to sink the sensors into the grill above the plate holder, so the sensor faces are flush with the grill & then bond them in place, now I have working sensors with no false positives.

I have to say I'm very very unhappy with the seller, ignores any feedback to fix a possible issue, even on facebook, the fact I took a hell of allot of time testing positions & ways to fix it, fed this back & they did squat to resolve is ridiculous, which is why I will not advise my clients to buy from.
 
Last edited:
Trust me the brackets are useless, I used them & as I advised the seller numerous times & ignored me everytime practically, the sensors are recessed to deep into the grill with these brackets & pickup the sides of the grill as an obstacle, I've tested many things & the only fix was to adjust 2 honeycomb sockets with a dremel to sink the sensors into the grill above the plate holder, so the sensor faces are flush with the grill & then bond them in place, now I have working sensors with no false positives.

I have to ay I'm very very unhappy with the seller, ignores any feedback to fix a possible issue, even on facebook, the fact I took a hell of allot of time testing positions & ways to fix it, fed this back & they did squat to resolve is ridiculous, which is why I will not advise my clients to buy from.

Ok, do you have any photos? I instantly picked up on the sensor needing to be flush with the grill. The guy in the garage who changed it suggested that but definitely a no-no.

Do you have pics of yours?
 
Guys reviving this thread im in the same position parking sensors aren't working can anybody help??
 
Adjust the inside of the grill so sensors can sit flush with the front of the grill, then use something like innotec topfix to bond in position, no issues at all with this.