2014 1.8 TFSI quattro in limp-home mode

My A3 went into limp home mode on the journey back home tonight. EPC light on, power very limited, coolant temp on min and electric fans on full. I keep a Carista dongle in the car, so I scanned it when I got home and it returned four errors:

P00B7 - Engine Coolant Flow Low/Performance
P0116 - Engine Coolant Temperature Sensor 1 Circuit Range / Performance
P2556 - Engine Coolant Level Sensor/Switch Circuit
P2681 - Engine Coolant Bypass Valve Control Circuit/Open

I haven't opened the coolant tank to see if it's dumped out yet.

Thoughts? Water pump? Thermostat? Or dodgy sensor?
 
West London Audi finally looked at this last week and diagnosed a faulty coolant pressure switch, which they changed and tested. Based on a bit of research, I thought this was unlikely and the problem was more likely to be the water pump and associated coolant management package. Went to pick it up on Friday, didn't even get off their forecourt before the Check Engine light came on. Back into their workshop, awaiting to hear. Would be very surprised not to be belatedly joining the 8V Water Pump Club...
 
As will surprise absolutely nobody, the more detailed diagnosis that Audi have carried out has discovered that the thermostat is leaking and has corroded the pins and wiring on the loom also. Obviously they're having to repair the loom and change the thermostat, but based on the hideous cost of the labour part of this operation alone I've instructed them to also change the water pump as a matter of course. Goodbye most of last year's tax refund...
 
Top