1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

2007 audi a6 c6 avant boost issue

Matthewa6c6 Sep 20, 2020

  1. Matthewa6c6

    Matthewa6c6 New Member

    2
    0
    1
    Hi guys just joined first post.

    I bought an a6 avant s line 2.0 tdi manual with the bre engine in 2010. It ran fine for 3 years then oil pump issue.

    Had the pump key balance shaft can't really remember what they done but it was everything required apparently. New turbo fitted then started egr cooler issues.

    So replaced that after having a high pitched whine under boost. Oem manufacturers part as I had a warranty deal which also was a pain to deal with.

    That lasted a year and a half couldn't swap it as left the garage I worked in when I ordered it, I'm a mechanic. So second hand one fitted lasted 3 months or so then filled its nappy. Changed this again then the turbo went. Lost faith.

    Sat off the road for a few years and here we are now.

    Changed turbo (cheap ebay for now) changed pipe connecting egr cooler to valve. Removed and cleaned egr valve too.

    Built it up took it a drive boost wasn't kicking in until 3 grand and smokey. The car has also had a generic map from a nervous mobile guy.

    So egr cooler has a small split in the metal pipe again.

    Tomorrow I'm going to change this again to the old one as I'm unsure of that was broken or not I've got that many lying around now.

    I'm just seeking opinions on what's going on here it's got me going round in circles.

    Next question egr removal.
    If I blank it off will the car run fine just have my eml lamp on? Or do i need to map this out to get performance.

    Thanks
     

    Attached Files:

  2. Avatar

    snack-media
    Advertisement


  3. Pie-eyedpiper

    Pie-eyedpiper Registered User

    807
    332
    63
    I've got the BRE in my A4.
    Was having no problem with the EGR but as per a previous 1.9 TDI I fitted a delete kit and removed the cooler too.
    As I wasn't having any issues I can't comment on any difference, seems to run just the same. Removing the cooler eliminates any possible coolant leaks and it enables me to access the turbo easily for "servicing" it.
    The EML light stays lit but was this was mapped out during my stage 1 remap.
     
  4. Matthewa6c6

    Matthewa6c6 New Member

    2
    0
    1
    Thought I'd finally upload a photo. Manky but it's winter
     

    Attached Files:

Share This Page

Do Not Sell My Personal Information