1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

2007 A4 B7 2.0 TDI Cabriolet - White Smoke & Flashing Glow Plug Light on start up - Help!

Springer* Sep 16, 2020 at 12:31 PM

  1. Springer*

    Springer* Registered User

    186
    21
    18
    Hi all,

    My trusty old 2007 A4 Cabriolet has developed some issues that I'm struggling to get properly diagnosed and I wonder if you kind folks have experienced similar and could shed some light on it for me?

    Car struggles to start intermittently when cold. Some days its starts instantly, but others it cranks for a good 30 seconds or more before spluttering into life. No error codes at all.

    Also, when the car is cold its very smoky even under minimal load with a lot of white smoke. Performance seems largely unaffected and once the car warms up it clears.

    Finally, on the odd occasion once on the move and the car is still cold, there is an intermittent flashing of the glow plug light on the dashboard and the car feels like its in limp mode with minimal boost and loads of white smoke. Then, after maybe 30 seconds it seems to sort itself out, boost is restored and performance returns to normal. :wtf:

    After a bit of Googling (fatal I know), it seems to point to glow plugs which at nearly 190k miles I'm sure are worn out, but then I'm told that these are only really used when the temperature is very low (i.e. not during late summer).

    Does anyone have an experience of this intermittent behaviour? Is this something that is common and can be easily rectified or is the engine goosed? Can anyone help?

    J:)
     

Share This Page

Do Not Sell My Personal Information