1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

2007 A4 B7 2.0 TDI Cabriolet - Starting Issues

Springer* Jan 16, 2020 at 12:52 PM

  1. Springer*

    Springer* Member

    180
    21
    18
    Hi there,

    My wife's 2007 Audi A4 B7 2.0 TDI S-Line Cabriolet has recently developed starting issues.

    Seems to affect the car mostly when completely cold (i.e. first thing on a morning) and the starter turns over fine, but it can take anything up to 30 seconds for the engine to begin to splutter into life.

    Once the car starts, the engine runs perfectly smoothly and drives fine.

    The car has high mileage (just over 182k) and all servicing is up to date and as it should be. I recently had the EGR and intake manifold completely stripped down and de-sludged too, so they are working perfectly.

    Could anyone shed any light on what it might be, or has anyone had similar issues?

    I'm thinking that the fuel pump is okay given that it runs fine once started. The starter seems fine too and the engine isn't sludged up any more. All hoses and air filter seem to be perfectly fine and the fuel filter was changed maybe 12 months ago too.

    I'm thinking possibly glow plugs, given the age/mileage..?

    Any ideas would be a great help.

    J:)
     
  2. Avatar

    snack-media
    Advertisement


  3. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    30,757
    2,081
    113
    Once started, does it start perfectly afterwards & then a long non use the issue happens again?
     
  4. Springer*

    Springer* Member

    180
    21
    18
    Yes, that's exactly what it does.

    J:)
     

Share This Page

Do Not Sell My Personal Information