1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.7t evap system/charcoal canister - anyone clued up on this?

VAG-Slag Jan 23, 2018

  1. VAG-Slag

    VAG-Slag Well-Known Member

    1,818
    431
    83
    I think I have a problem with my fuel system breather, but I don't know enough about how it works to pass judgement!?

    I've previously noticed a slight woosh of air as I open the fuel cap, suggesting it's not venting properly... And also (not sure if it's related) often an odd whistle when I shut the engine off.

    Recently, after a drive in the rain, I noticed a gargling sound from under the car on the drivers side. On closer inspection there was a pipe right under the drives seat (pretty sure it's part of the charcoal canister breather) that was sucking up air, water and what ever else it found under the car!

    I put my thumb over the pipe and there was a proper vacuum there while idling, but I can't imagine why it would be sucking in so much air/water and where it's going!? . .

    Just doesn't seem right - anyone able to elaborate on this at all?
     
  2. Avatar

    Google AdSense Advertisement


  3. QuattroCalum

    QuattroCalum Well-Known Member Team Avus Silver saloon Audi A4 quattro Manual

    1,855
    676
    113
    It must have come apart at a connection, it should run to the charcoal canister which is behind the drivers side front wing splash guard. Jack it up and take the wheel off and remove the splash guards ( it’s just a few torx screws) you should be able to follow the pipe work from there and sort the problem.


    Sent from my iPhone using Tapatalk
     
  4. VAG-Slag

    VAG-Slag Well-Known Member

    1,818
    431
    83
    Thanks for the reply...

    Connection where though?.. The open pipe is secured and looks like it's supposed to be there:

    20180121_142203.jpg

    And it must be connected to something at the other end otherwise it wouldn't be sucking up air...

    Unless I'm missing your point?
     
  5. QuattroCalum

    QuattroCalum Well-Known Member Team Avus Silver saloon Audi A4 quattro Manual

    1,855
    676
    113
    That’s why I suggest removing the splash guard and see what’s missing or where those pipes lead.


    Sent from my iPhone using Tapatalk
     
  6. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    18,722
    895
    113
    thats some sort of drain from the carbon can. I dont think it should be sucking stuff up.
     
  7. VAG-Slag

    VAG-Slag Well-Known Member

    1,818
    431
    83
    Thank makes more sense... My concern is that vacuum can only be coming from the inlet and that it's sucking stuff straight into the engine!?

    I'll trace it back and see what I can find
     
    mojocvh likes this.
  8. QuattroCalum

    QuattroCalum Well-Known Member Team Avus Silver saloon Audi A4 quattro Manual

    1,855
    676
    113
    Could be the one way valve has failed allowing vacuum from turbo inlet pipe (if it’s similar set up to 1.8t) the solenoid should purge tank gasses to tip, there’s a one way valve just after the solenoid.


    Sent from my iPhone using Tapatalk
     
  9. VAG-Slag

    VAG-Slag Well-Known Member

    1,818
    431
    83
    The car is on axle stands at the moment anyway... I'll have a poke about on the weekend!

    Thanks for your input guys *thumbs up emoji*
     
  10. QuattroCalum

    QuattroCalum Well-Known Member Team Avus Silver saloon Audi A4 quattro Manual

    1,855
    676
    113
    Hope you find out what the problem is


    Sent from my iPhone using Tapatalk
     
    VAG-Slag likes this.
  11. mojocvh

    mojocvh Member

    175
    17
    18
    Ha, I've got EXACTLY the same going on too with the solenoid chattering like crazy what controls/engages the solenoid electrically?
     
    kellsy79 likes this.
  12. Avatar

    Google AdSense Advertisement


  13. kellsy79

    kellsy79 New Member

    3
    0
    1
    Did anyone sort this problem as I'm having it now lol

    Sent from my SM-G930F using Tapatalk
     
  14. mojocvh

    mojocvh Member

    175
    17
    18
    058905291K vacume check valve. beside airbox. replaced it and issue seems resolved for the time now. Funny thing is it seemed solid when cold but who knows when hot....
     

Share This Page